[Slackbuilds-users] Build Issues On One of Two Machines

Rich Shepard rshepard at appl-ecosys.com
Sun Jan 25 03:36:50 UTC 2009

   A couple of days ago I successfully built the taskjuggler and tinyerp
packages on my notebook. Today both failed the build process on my
server/workstation desktop. Both machines run Slackware-12.2 with all
pertinent patches applied. I'd appreciate insight into what might be the
problems on the one host.

   TaskJuggler: complains it cannot find Qt. I have qt-3.3.8b, qt4-4.4.3
installed from SlackBuild scripts and qt4-4.2.2 installed from a tarball
build. I modified the taskjuggler.SlackBuild script to specify the qt4 root
directory, include directory, and lib directory. No joy. Tried again with
the paths to the 3.3.8b version. Still no joy. I'm at a loss what to do.

   tinyerp-client: the tinyerp-client.SlackBuild script quickly halts
displaying this:

Error: python module gtk (gtk python bindings) is required
Error: python module gtk.glade (glade python bindings) is required

yet, PyGTK is installed: pygtk-2.12.1-i486-2.

   Again, both built just fine on my notebook so I'm at a complete loss to
understand why they won't build on the server/workstation even when the
supposedly missing libraries are present.



Richard B. Shepard, Ph.D.               |  Integrity            Credibility
Applied Ecosystem Services, Inc.        |            Innovation
<http://www.appl-ecosys.com>     Voice: 503-667-4517      Fax: 503-667-8863

More information about the SlackBuilds-users mailing list