[Slackbuilds-users] Build Issues On One of Two Machines

Grissiom chaos.proton at gmail.com
Sun Jan 25 03:47:25 UTC 2009

On Sun, Jan 25, 2009 at 11:36, Rich Shepard <rshepard at appl-ecosys.com> wrote:
>  A couple of days ago I successfully built the taskjuggler and tinyerp
> packages on my notebook. Today both failed the build process on my
> server/workstation desktop. Both machines run Slackware-12.2 with all
> pertinent patches applied. I'd appreciate insight into what might be the
> problems on the one host.
>  TaskJuggler: complains it cannot find Qt. I have qt-3.3.8b, qt4-4.4.3
> installed from SlackBuild scripts and qt4-4.2.2 installed from a tarball
> build. I modified the taskjuggler.SlackBuild script to specify the qt4 root
> directory, include directory, and lib directory. No joy. Tried again with
> the paths to the 3.3.8b version. Still no joy. I'm at a loss what to do.

How did you modify the script?

>  tinyerp-client: the tinyerp-client.SlackBuild script quickly halts
> displaying this:
> Error: python module gtk (gtk python bindings) is required
> Error: python module gtk.glade (glade python bindings) is required
> yet, PyGTK is installed: pygtk-2.12.1-i486-2.

Could you please launch a python in the terminal and try "import
pygtk" to see there is any problem? Maybe you should launch python in
the way that the script does.

>  Again, both built just fine on my notebook so I'm at a complete loss to
> understand why they won't build on the server/workstation even when the
> supposedly missing libraries are present.

So, what is the environmental difference between your notebook and server?


More information about the SlackBuilds-users mailing list