[Slackbuilds-users] A few questions/remarks

Aleksandar Samardzic asamardzic at gmail.com
Tue Feb 2 12:17:49 UTC 2010

On Tue, Feb 2, 2010 at 12:13 AM, Serban Udrea
<serban.udrea at skmail.ikp.physik.tu-darmstadt.de> wrote:
> Aleksandar Samardzic wrote:
>> On Sun, Jan 31, 2010 at 2:07 AM, Serban Udrea
>> <serban.udrea at skmail.ikp.physik.tu-darmstadt.de> wrote:
>>> ... Thus, I think that it would be nice if
>>> someone could help with testing on such a machine, before I do the
>>> submission.
>> I'll be glad to help testing on 64-bit machine, please drop me a link
>> to your version of the SlackBuild.
> Hello,
> And please excuse the late answer. I am at a workshop and there have
> been some network problems here. The link is:
> http://www-linux.gsi.de/~udrea/atlas.tar.gz
> Thank you for the testing!

OK, I've just tested it:

My machine is HP EliteBook 8530w, with Core 2 Duo P8600 @2.4GHz.  My
Slackware installation is Slackware64 13.0, with all upgrades from
-current (which in particular means my gcc is 4.4.3).  I've built
Atlas according to the instructions from README file from the archive
above - the only change I've made is that I've defined
USE_ARCH_DEFAULTS to "yes" in my root shell before starting the
SlackBuild script. Everything went OK with the build, and I tried the
library after installing it, using a simple SGEMM code of mine that I
use for crude measuring of GFLOPS, and I got same results as with
version of Atlas that I had installed from source previously (which is
as expected, as my manual build procedure was practically the same as
one you use in the SlackBuild).  Then I tried it with some other codes
of mine, and everything seems to be working fine.  I've also installed
LAPACK from SlackBuilds.org afterwards, and tried it with another
simple program of mine, and again everything seems OK.

Afterwards, I tried to build Atlas with USE_ARCH_DEFAULTS set to "no".
 After more than 3 hours of melting my CPU, the build went OK, but
there was an error reported in "make check" phase:
gfortran -O -fPIC -m64 -o xzuumtst zuumtst.o \
/tmp/SBo/atlas-3.8.3/BuildDir/lib/libatlas.a -lpthread -lm
/tmp/SBo/atlas-3.8.3/BuildDir/bin xzslvtst -n 167 -r 83 -O 2 c r \
                  >> /tmp/SBo/atlas-3.8.3/BuildDir/bin/sanity.out
RHS=1, nrm=815354219683.353271
RHS=2, nrm=764055770646.382446
RHS=3, nrm=915347149357.361572

  [ ... ]

RHS=81, nrm=2088682204388.245605
RHS=82, nrm=487952492701.210205
RHS=83, nrm=855863583301.543579
make[3]: *** [zsanity_test] Error 2
make[3]: Leaving directory `/tmp/SBo/atlas-3.8.3/BuildDir/bin'
make[2]: *** [sanity_test] Error 2
make[2]: Leaving directory `/tmp/SBo/atlas-3.8.3/BuildDir/bin'
make[1]: *** [sanity_test] Error 2
make[1]: Leaving directory `/tmp/SBo/atlas-3.8.3/BuildDir'
make: *** [test] Error 2
and the corresponding excerpt from sanity.out is:
   [ ... ]

4 cases: 4 passed, 0 skipped, 0 failed
ORD  UPLO       N    NRHS     lda     ldb       TIME     MFLOP        RESID
===  ====  ======  ======  ======  ======  =========  ========  ===========

  C     G     167      83     167     167      0.010   2107.46  1.413844e+13
  R     G     167      83     167     167      0.010   2200.96  2.592634e+13

However, I wouldn't worry too much about it: I always compile using
architectural defaults (moreover - if I understand it properly, this
is what Atlas developers are suggesting to do for common
architectures, so I would be even tempted to put USE_ARCH_DEFAULTS to
"yes" in the SlackBuild) thus I never encountered this error before,
but it's probably something about my processor, or compiler, or
whatever - in any case, most probably nothing related with your

While it would be good if someone else could try to test it, I'd say
you SlackBuild works fine on Slackware64, and I hope you soon upload
it to SlackBuilds.org.  Kudos for the great work: Atlas is certainly
one of the most complex pieces of OSS to create distribution package
for, and it is great that Slackware will have it supported at last.


More information about the SlackBuilds-users mailing list