[Slackbuilds-users] EncFS requres boost <= 1.41

Niels Horn niels.horn at gmail.com
Fri Jun 4 21:32:24 UTC 2010

On Fri, Jun 4, 2010 at 6:06 PM, Ben Mendis <dragonwisard at gmail.com> wrote:
> Since I was already using EncFS in 13.0 I went ahead and tried to compile it
> for 13.1. There's one "invalid conversion from 'const char*' to 'char*'"
> error to fix, but even after fixing that the resulting binary doesn't work.
> Apparently the problem is that Slackware 13.1 has upgraded to boost 1.42.0
> and encfs requires 1.41 or earlier.
> See: http://code.google.com/p/encfs/issues/detail?id=60
> Therefore my question is, is it feasible to install boost-1.41 side-by-side
> with the boost-1.42 provided by Slackware?
> Does anyone have any advice on how this can be resolved?

Ouch... Just read the posts on that page. Sounds like a really ugly
situation to me.

I think a solution could be statically linking the "old" boost library
into EncFS.
But I haven't tried this (and don't have time to try it in the
foreseeable future), so YMMV...

Side-by-side installation of the two boost versions is a guarantee to
other problems IMHO.


More information about the SlackBuilds-users mailing list