[Slackbuilds-users] EncFS requres boost <= 1.41

Heinz Wiesinger pprkut at liwjatan.at
Fri Jun 4 21:36:53 UTC 2010

On Friday 04 June 2010 23:32:24 Niels Horn wrote:
> On Fri, Jun 4, 2010 at 6:06 PM, Ben Mendis <dragonwisard at gmail.com> wrote:
> > Since I was already using EncFS in 13.0 I went ahead and tried to compile
> > it for 13.1. There's one "invalid conversion from 'const char*' to
> > 'char*'" error to fix, but even after fixing that the resulting binary
> > doesn't work. Apparently the problem is that Slackware 13.1 has upgraded
> > to boost 1.42.0 and encfs requires 1.41 or earlier.
> > 
> > See: http://code.google.com/p/encfs/issues/detail?id=60
> > 
> > Therefore my question is, is it feasible to install boost-1.41
> > side-by-side with the boost-1.42 provided by Slackware?
> > Does anyone have any advice on how this can be resolved?
> Ouch... Just read the posts on that page. Sounds like a really ugly
> situation to me.
> I think a solution could be statically linking the "old" boost library
> into EncFS.
> But I haven't tried this (and don't have time to try it in the
> foreseeable future), so YMMV...
> Side-by-side installation of the two boost versions is a guarantee to
> other problems IMHO.

IMHO this is clearly a case where waiting for upstream to fix it is the most 
feasible option. The boost bugreport 
(https://svn.boost.org/trac/boost/ticket/3990) clearly states the fix needs to 
be in encfs. Until the fix is available I'm not going to submit encfs for 13.1 
(no matter what hack might be suggested as a "solution").

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20100604/d50633c8/attachment.sig>

More information about the SlackBuilds-users mailing list