[Slackbuilds-users] wireshark issues

Chris ABELA chris.abela at maltats.com
Tue Oct 11 13:38:22 UTC 2011

I have an updated 13.37 32 bit installation plus 117 SBo packages, nothing


I upgraded wireshark to 1.6.1 from 1.4.6 and it fails to start:


~ $ wireshark 

wireshark: error while loading shared libraries: libwsutil.so.0: cannot open
shared object file: No such file or directory

~ $


wireshark 1.4.6 works/worked fine.


This was solved as follows:


# cd /usr/lib

# ln -s libwsutil.so.1.0.0 libwsutil.so.0


And similarly:


# ln -s libwiretrap.so.1.0.0 libwiretrap.so.0


(BTW I wonder if this would unleash a dependency hell in other distros)



I also failed to start wireshark in the recommended method in the README:


/sbin/setcap cap_net_raw,cap_net_admin=eip /usr/bin/dumpcap

unable to set CAP_SETFCAP effective capability: Operation not permitted


Actually, normally I rely on kdesu to start wireshark, as otherwise dumpcap
looks similar to tcpdump, which is not what I want, but I would appreciate
an explanation on how it should work.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20111011/73a78608/attachment.html>

More information about the SlackBuilds-users mailing list