[Slackbuilds-users] Problem with 'faenza-xfce'

Chess Griffin chess at chessgriffin.com
Thu Aug 9 01:48:50 UTC 2012

On Wed, Aug 8, 2012, at 10:44 AM, Chess Griffin wrote:
> On Wed, Aug 8, 2012, at 08:18 AM, Nicolas Kovacs wrote:
> > Le 08/08/2012 13:48, Chess Griffin a écrit :
> > > Nope.  I just used sbopkg to download, build, and install this package
> > > and everything worked fine.  It grabbed the source from the github link
> > > without issue.  No mysterious 0.2.1 file or other problems.
> > 
> > I'm puzzled, because I can reproduce this behaviour on two different 
> > machines. Nothing exotic in my setup, though, except maybe the use of a 
> > proxy (Squid).
> > 
> Well, now I'm puzzled too because I tried this on another system at work
> and now I get the same thing you reported -- sbopkg is saving the
> downloaded file as 'v.0.2.1' and then the build fails.  Not sure why it
> worked on my machine at home last night.
> Thanks for the heads up.  Further discussion should probably take place
> on the sbopkg mailing list.

Nicolas - 

One final follow-up in case you are not subscribed to the sbopkg mailing
list.  The reason why we got different results is that I initially
tested it on my -current x86_64 setup and the faenza-xfce source
downloads and sbopkg builds it and it installs fine.  But at work, on my
13.37 box, I had the same odd result that you reported.  Mauro Giachero
found a possible workaround using the --content-disposition wget flag,
so it appears that wget wassn't parsing the download correctly.  Perhaps
something changed in wget's parsing ability that fixed this download
issue on -current.  13.37 shipped with wget 1.12 and -current has

Ok, I'll shut up about this now on this list and continue on
sbopkg-users. ;-)

Chess Griffin

More information about the SlackBuilds-users mailing list