[Slackbuilds-users] Qemu-kvm

King Beowulf kingbeowulf at gmail.com
Mon May 6 03:57:36 UTC 2013

On 05/05/2013 12:14 PM, John Yost wrote:
> On 05/04/2013 11:37 PM, King Beowulf wrote:
>> On 05/04/2013 02:47 PM, John Yost wrote:
>>> I tried to upgrade to the latest Qemu version 1.4.0. The upgrade went
>>> fine. I did not use usbdir or spice, just the basic Qemu.
>>> When I tried to start the VM with my usual command line .....
>>> "qemu-kvm -usb -ctrl-grab -m 4096 -soundhw es1370 -localtime -vga std
>>> -cdrom /dev/cdrom /mnt/other/VM/winxp.img"
>> ---snip--------
>> I am not running any windows VMs at the moment, but a snippet from AQEMU
>> front end running Slackware is:
>> -net nic,vlan=0,macaddr=00:f7:a5:88:89:c1,model=virtio
>> -net user,vlan=0,hostname=phantom32
>> change hostname, macaddr, model as needed. I think, more simply you may
>> only need
>> -netdev user,id=xxxxx
> Tried but no cigar. In the terminal i get "no vlan" or "vlan not
> connected to host network" "Warning: vlan 0 with no nics"
> Don't know what the"id=xxxx" is supposed to be.
> I thought there was supposed to be a simple default network connection
> without any needed setup. The qemu manpage seems to indicate there is a
> default automatic network connection.
> Any direction would be greatly appreciated. Don't know how many times Xp
> can be re-certified before I get refused.

Since WinXP is dead its anyone's guess how long the activation servers
will be up.  There are ways to bypass activation.

I dredged up my old WinXP CD and fired up a VM (I will never forgive you
foe that!).  Looks like qemu uses a default nic that WinXP does not
recognize, even after installing Service Pack 3.  Here is my command to
have WinXP automagically detect and install the NIC driver (adjust as

$ qemu-kvm -m 768 -hda winxp.img -cdrom /dev/dvd -net nic,model=pcnet
-net user

Adjust as needed.

For the future:

>From the qemu manpage: "The NIC is an e1000 by default on the PC
target." Now check WinXP device manager, ooo! yellow ? for ethernet
controller; right click properties, update driver, etc etc look at
driver list....mmm no driver, lets try another nic ...

Just sayin'...


More information about the SlackBuilds-users mailing list