[Slackbuilds-users] Bash: long lines do not wrap but shift left [RESOLVED]

e20100633 e20100633 at gmail.com
Tue Apr 29 17:33:35 UTC 2014

Rich Shepard <rshepard at appl-ecosys.com> writes:

>   Problem solved, but I don't know why.
>   I changed the default COLORTERM in ~/.bash_profile to just rxvt, sourced
> the file, and still could not properly display the UFT-8 test file.

Actually I tried, too, to just source ~/.profile after changing TERM,
but it didn't worked ; I had to launch an other instance of urxvt.

> Next, I edited rxvt-unicode.SlackBuild to not include the perl
> interpreter; built and installed it.

If you're using SBo you could just make :

 # CONFIG_PERL=NO sbopkg -i rxvt-unicode

>   Now, setting COLORTERM back to `rxvt-unicode-256color' and the vts
> (including the one in which alpine runs), the UTF-8 file is readable and
> long command lines no longer wrap.
>   I don't know if it was removing the perl interpreter from rxvt-unicode or
> just rebuilding and re-installing it, but it now again works as it did.

Interesting. I'm using the perl interpreter but I can perhaps do
without, I'll see; but at least I have to try compiling without the perl
interpreter too and see the results. Thank you for the feedback Rich!


PS: oh and sorry, I send my previous response directly to your mailbox
and just CC the list; hoping it didn't disturb you too much :)

~ #ID: e20100633 <e20100633()inbox!lv> #TTY: 9-8M 4554
~ TYPE 1707-A3 S/N L3-M2812 SLACKWARE 13.0 RLU #527034
,------- They say that Nethack bugs are Seldon planned
`-----------------------{,_,"> http://porneia.free.fr/

More information about the SlackBuilds-users mailing list