[Slackbuilds-users] Bash: long lines do not wrap but shift left [RESOLVED]

Timothy Pollard timp at timp.com.au
Tue Apr 29 22:26:59 UTC 2014

On Tue, 29 Apr 2014 19:33:35 +0200
e20100633 <e20100633 at gmail.com> wrote:
> Rich Shepard <rshepard at appl-ecosys.com> writes:
> >   Problem solved, but I don't know why.
> >
> >   I changed the default COLORTERM in ~/.bash_profile to just rxvt, sourced
> > the file, and still could not properly display the UFT-8 test file.
> Actually I tried, too, to just source ~/.profile after changing TERM,
> but it didn't worked ; I had to launch an other instance of urxvt.
> > Next, I edited rxvt-unicode.SlackBuild to not include the perl
> > interpreter; built and installed it.
> If you're using SBo you could just make :
>  # CONFIG_PERL=NO sbopkg -i rxvt-unicode
> >   Now, setting COLORTERM back to `rxvt-unicode-256color' and the vts
> > (including the one in which alpine runs), the UTF-8 file is readable and
> > long command lines no longer wrap.
> >
> >   I don't know if it was removing the perl interpreter from rxvt-unicode or
> > just rebuilding and re-installing it, but it now again works as it did.
> Interesting. I'm using the perl interpreter but I can perhaps do
> without, I'll see; but at least I have to try compiling without the perl
> interpreter too and see the results. Thank you for the feedback Rich!
> e201-,
> PS: oh and sorry, I send my previous response directly to your mailbox
> and just CC the list; hoping it didn't disturb you too much :)

That's odd. I have Perl enabled in urxvt (and I upgraded to the latest version
this morning), but horizontal-scroll-mode Off/On in .inputrc seems to work
fine for me, and my TERM is set to rxvt-unicode-256color, oddly the default if
I remove that line entirely seems to be Off ("normal" wrapping), but I can set
it to On if I want to. Maybe it's inheriting the values from the other
terminals though.

Though I set it ages ago to fix the problem with lines not wrapping, so maybe
changed something else at the same time that fixed it; I can't think what

Maybe you have something different in your /etc/inputrc, or something else
to do with readline?

It could be worth checking what bind -v | grep horizontal says as well.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20140430/aeabede8/attachment.asc>

More information about the SlackBuilds-users mailing list