[Slackbuilds-users] Error while installing package fontforge (20141014)

enigma enigma77 at gmx.net
Wed Dec 10 10:08:50 UTC 2014

Am Dienstag, 9. Dezember 2014, 23:17:18 schrieb Kyle Guinn:
> On 12/9/14, Christoph Willing <chris.willing at iinet.net.au> wrote:
> > Maybe multilib can be implicated in the fontforge build failures but I
> > think there's some other factor involved too.
> I tried building it about a week ago or so, got what I believe is the
> same error.  It's on a 64-bit machine, but that machine is not and has
> never been multilib.  Must be a conflict with some other package.  I
> haven't had time to narrow it down yet.
> Just a hunch, maybe it's conflicting with an older version of fontforge?
> -Kyle
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - http://slackbuilds.org/faq/

Is it possible that it has something to do with the way we upgrade our multilib libraries?

I do it manually (no slackpkg+ or something similar).

Therefor I download the Repo in a separate directory (not /tmp/multilib/) and diff the files with them in /tmp/multilib.

Here my Way to upgrade the multilib:

				# SLACKVER=14.1
# mkdir /home/foo/downloads/and.not.tmp.multilib
# cd and.not.tmp.multilib/
# lftp -c "open http://taper.alienbase.nl/mirrors/people/alien/multilib/ ; mirror -c -e ${SLACKVER}"

				# diff -r and.not.tmp.multilib/ /tmp/multilib
				# cp different.files /tm/multilib/	
				# rm /tmp/multilib/old.version.of.different.files		

				# cd /tmp/multilib/14.1/
# upgradepkg --reinstall --install-new *.t?z
# upgradepkg --install-new slackware64-compat32/*-compat32/*.t?z 

Now I have some questions:

1.)	Is it possible, that my Way to upgrade the multilib-files, confused my system?
	For example, I do not first upgrade the original 64-bit files (e.g. glibc), but simply overwrite the old multilib-files with the new multilib-files, as described above.

2.)	Should i next time first upgrade the original 64bit packages (so that the multilib-packets are replaced by the original), before i again upgrade these with the
	multilib-packages from alienbobs repo?  Or is it irrelevant?  

3.)	Whats the best Way to upgrade the multilib-files?

4.)	In the case that my multilib-system actually has errors, what is the best way to synchronize my system with the current alien slackware64 14.1 Repository?

After i synchronize my system and if the Build process still failed with an error, i can at least assume that it's not the multilib system and so i can turn my attention to other causes.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20141210/e1472aaa/attachment-0001.html>

More information about the SlackBuilds-users mailing list