[Slackbuilds-users] texlive slackbuild produces a broken xindy.(14.1, 20140525)

Robby Workman rworkman at slackbuilds.org
Fri Dec 12 05:13:59 UTC 2014

On Thu, 11 Dec 2014 22:09:27 +0000
Ken Moffat <zarniwhoop at ntlworld.com> wrote:

> Hi,
> Introductory history to explain why I'm reporting this -
>  I've ended up taking (some) responsibility for texlive at another
> place [1] and some while ago we got notified that _our_ build
> (starting from the binary install-tl-unx) was not buildng xindy (an
> indexing tool, used by 'makeglossaries').
>  At that time, I could not find out how to _use_ it, so I delayed
> adding it.  Eventually I found an example, which I adapted and got
> working (well, it works on our x86_64, but not on i686 - that part
> is *my* problem).
>  Because I wanted to be able to run tests to check that things still
> worked after an upgrade, I started preparing some test scripts.  And
> then I decided to try to make them more generally useful, and also
> to ensure that I could look for texlive OTF/TTF fonts wherever they
> had been installed.  For that, I've been using qemu.
> And now, the problem:
> On the (64-bit) slackbuild, xindy gets built but it is broken.  I've
> now found an easier test (which works for me on both i686 and x86_64
> and does not need modern fonts, and does actually error if it fails:
> tug.ctan.org/macros/latex/contrib/glossaries/samples/samplexdy.tex
> (I assume wget will be able to download thet, I used firefox).
>  This creates three somewhat sparse pages, followed by two pages of
> glossary.  The commands to run it to create a PDF are:
> $latex samplexdy
> $makeglossaries samplexdy
> $pdflatex samplexdy
>  but on your 64-bit it initially fails with
> ***Call to xindy failed***
> Check 'samplexdy.glg' for details
>  which said among other things
> xindy: Cannot locate /usr/lib64/xindy.mem at /usr/bin/xindy line
> 519.
>  Well, xindy.mem is in /usr/bin so I made a symlink and tried again.
> But makeglossaries still fails:
> xindy -L general -I xindy -M "samplexdy" -t "samplexdy.glg" -o
> "samplexdy.gls! "samplexdy.glo"
> Cannot locate xindy module for language general.
> ***Call to xindy failed***
> Check 'samplexdy.glg' for details
>  - that now contains:
> *** Unable to execute: '"xindy" -L english -C utf8 -I xindy -M
> "samplexdy" -t "samplexdy.glg" -o "samplexdy.gls" "samplexdy.glo"'
> ***
> Failed with error code 1.
> Status report:
> Cannot locate xindy module for language english in codepage utf8.
>  At that point, I gave up.  No idea why it said 'language general'
> when it is actually trying to use english.  I wonder if, perhaps,
> a UTF-8 locale is needed to build xindy.
>  I'm not subscribed, but if you need to contact me, the address I'm
> sending from should work.
>  This is a somewhat niche part of tex, I can understand if you do
> not care about it.  If somebdy wants to look at it, it might be
> easiest to start with the separate xindy-2.5.0 tarball at
> http://www.ctan.org/tex-archive/indexing/xindy/base to save having
> to build all of texlive.
> ĸen
> [1.] beyond.linuxfromscratch.org

Hi Ken,

I've recently gotten another report that Xindy is broken, so you're
not the only one. It's on my TODO list, but I'm a bit stretched thin
right now, so if anyone has some spare cycles and can figure it out 
and send us a patch, I'd be quite grateful.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20141211/7a5254e3/attachment.asc>

More information about the SlackBuilds-users mailing list