[Slackbuilds-users] eclipse issues and current(?)

Miguel De Anda miguel at thedeanda.com
Mon Jan 6 02:59:24 UTC 2014

On Sun, Jan 5, 2014 at 4:11 PM, Antonio Hernández Blas <
hba.nihilismus at gmail.com> wrote:

> On Sun, Jan 5, 2014 at 2:40 PM, Miguel De Anda <miguel at thedeanda.com>wrote:
>> for some reason the eclipse package on sbo requires webkitgtk whereas one
>> (forgot which packaging) from eclipse.org doesn't.
> The "SBo's eclipse" *it is* from eclipse.org, specifically the "Eclipse
> Standard" (aka "classic"). Anyway, it does not requires webkit or xulrunner
> if you do not use its internal web browser, by default it will use your
> system web browser (firefox mostly). There has been some reports/solutions
> in the past about this issue [1][2]

I'll have to see which I had manually downloaded that worked -- I've since
removed the packages that I thought were causing the problem and it worked
but caused a separate issue (I'll describe below). i also read through the
build script and it doesn't seem to do anything odd with the download so
its just a matter of comparing downloads i guess.

> i've installed all of these from sbo and it seems to make eclipse crash
>> quite a bit.
> That seems to be the normal behavior ;)

The strange thing was that I hadn't touched eclipse. It was installed from
the sbo script at least a few weeks before and the only things I touched
were packages (and deps) for midori -- i don't think i had any of the
gtkwebkit stuff installed before so adding this package might have
triggered it to try to use a different browser plugin.

>> i just wanted to share my findings in case there are other eclipse users
>> out there.
> I stopped using eclipse from SBo and just downloaded/installed the "Eclipse
> IDE for Java Developers" and "Eclipse IDE for Java EE Developers" in my
> $HOME with a shell script in my $PATH to execute them. The benefit is that
> you can more easily install/upgrade eclipse and its plugins. BTW, "Eclipse
> Standard" it means to be used by "eclipse developers" (plugins and such)
> and not by "java-jee-c-c++" developers since it's the "Eclipse Platform".

I often run it this way but I figured it'd also be useful to help run the
sbo script to have more eyes on those build scripts and the packages they


so today i realized that something i removed broke my kde!!! i think
gstreamer1 or the way i installed it. the missing library was found in both
gstreamer and gstreamer1 packages. i'll have to see how sbopkg installed it
(alongside or replacement). i think this was the issue that was ultimately
causing the eclipse problem. i'll spend a few hours tomorrow and see if i
can recreate the problem to pinpoint the cause and at least report it in
case other run into this as well. i simply reinstalled original gstreamer
and kde ran fine again.



> - Cheers
> [1]
> http://lists.slackbuilds.org/pipermail/slackbuilds-users/2011-May/007356.html
> [2]
> http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-June/005979.html
> --
> Antonio Hernández Blas | Oaxaca, México, Mx.
> https://github.com/nihilismus | https://bitbucket.org/nihilismus |
> https://twitter.com/nihilipster
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - http://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20140105/ca724fb0/attachment-0001.html>

More information about the SlackBuilds-users mailing list