[Slackbuilds-users] Unable to build qt5 5.5.0

Christoph Willing chris.willing at iinet.net.au
Fri Oct 2 11:08:29 UTC 2015

On 02/10/15 17:50, Christopher Culver wrote:
> David Spencer <baildon.research at googlemail.com>
> writes:
>> The .pc file is (or should be) created in
>> qt-everywhere-opensource-src-5.5.0/qtwebkit/lib/pkgconfig at the same
>> time as the shared libraries in the containing directory.
>> AFAICT the command line that is reporting that error should be something like
>> sed -e 's,[^ '\'']*/tmp/SBo/qt-everywhere-opensource-src-5.5.0/[^/][^/]*/lib,,g'
>> ../lib/pkgconfig/Qt5WebKit.pc >
>> /tmp/SBo/package-qt5/usr/lib64/pkgconfig/Qt5WebKit.pc
> I suppose. I cannot see the actual sed command, I just get the
> aforementioned error that sed dumps.
> However, there is no Qt5WebKit.pc file in either the source or the
> package directories.

That Qt5WebKit.pc file is processed twice with sed; first by 'make 
install' command which takes Qt5WebKit.pc from where it was  generated 
by 'make' (since its not in the 'raw' source after unpacking the source 
tarball) and deposited into the package-qt5 tree. The second sed 
occurrence is in the qt5.SlackBuild and its this instruction which you 
are seeing fail. Its probably failing because the first sed occurrence 
didn't succeed either - maybe 'make' didn't generate it in the first place.

If you can bear it, perhaps you could build again and keep a log file of 
the build - something like:
     sh ./qt5.SlackBuild 2>&1 | tee op
(op will be reasonably large ~50M).

In that log file, you should be able to search for Qt5WebKit.pc and find 
where 'make install' processed it (or not) with sed. Look for warnings 
and errors in that area of the  log file and you may find what is going 

> Because Pulseaudio is required for Qt's web engine according to a
> comment in the Slackbuild, and I do have Pulseaudio installed on my
> system, I also tried running the build as USEPULSE=yes ./qt5.SlackBuild,
> but this has no effect and I still get the error.

That shouldn't make any difference. FWIW, I use USEPULSE=yes and my 
Qt5WebKit.pc appears as expected. I only started using that option 
fairly recently and didn't have problems with previous versions when I 
didn't use it.


More information about the SlackBuilds-users mailing list