[Slackbuilds-users] Unable to build qt5 5.5.0

Christopher Culver crculver at christopherculver.com
Fri Oct 2 07:50:23 UTC 2015

David Spencer <baildon.research at googlemail.com>
> The .pc file is (or should be) created in
> qt-everywhere-opensource-src-5.5.0/qtwebkit/lib/pkgconfig at the same
> time as the shared libraries in the containing directory.
> AFAICT the command line that is reporting that error should be something like
> sed -e 's,[^ '\'']*/tmp/SBo/qt-everywhere-opensource-src-5.5.0/[^/][^/]*/lib,,g'
> ../lib/pkgconfig/Qt5WebKit.pc >
> /tmp/SBo/package-qt5/usr/lib64/pkgconfig/Qt5WebKit.pc

I suppose. I cannot see the actual sed command, I just get the
aforementioned error that sed dumps.

However, there is no Qt5WebKit.pc file in either the source or the
package directories.

> Apparently you are exporting TMP=/media/BUILD/sbotmp/ with a trailing
> slash.

I went ahead last night and freed up enough space that I did not need to
export TMP. Even with all the Slackware dir variables set to their
defaults, the SlackBuild still fails with the error that it cannot find

Because Pulseaudio is required for Qt's web engine according to a
comment in the Slackbuild, and I do have Pulseaudio installed on my
system, I also tried running the build as USEPULSE=yes ./qt5.SlackBuild,
but this has no effect and I still get the error.

More information about the SlackBuilds-users mailing list