[Slackbuilds-users] Building Stellarium from the 14.1 repositories

EM Uhill uhillem at gmail.com
Mon Oct 12 20:07:58 UTC 2015

I emailed this to the Stellarium maintainer, Alan Alberghini, without any
reply back, so I am posting it here on the mailing list so the Slackware
community can benefit from my experiences with building and installing
Stellarium with qt-5.5 installed as found in the Slack Builds 14.1

Hi there. I tried to install Stellarium 0.13.2 via your Slack Build script
only to find out it won't compile against qt-5.5. This is the only version
of qt on Slack builds for Slackware 14.1. Stellarium's website shows that
Stellarium 0.13.2 needs qt-5.2 to build. I haven't tried it, but I presume
that the qt-5.5 SlackBuild script would compile the 5.2 version of qt just
fine. However that takes 12 hours to build on my duo core machine. Since I
already had qt-5.5 built, I modified your SlackBuild script to build
Stellarium 0.13.3 and included a patch from the Gentoo website so it would
build against qt-5.5. The patch will not work with Stellarium 0.13.2
however. After I got it built and installed, I ended up finding out that
Stellarium 0.13.3 requires Mesa 10.x libraries to function at a decent
speed. After consulting Stellarium's website, I found out that all versions
of Stellarium after 0.12.4 require Mesa 10.x libs to be installed including
Stellarium 0.12.6. The Stellarium project recommends upgrading to one of
the Mesa 10.x libs to run any version of Stellarium after 0.12.4 or to use
0.12.4 for the Mesa 9.x libs.  As a result I have used your original
SlackBuild script to build and install Stellarium 0.12.4 and it works just
fine.  You'll probably want to update your Stellarium Slackbuild entry to
use Stellarium 0.13.3 for those who have one of the Mesa 10.x libs
installed and add another entry for Stellarium 0.12.4 for those who have
Mesa 9.x libs installed. Attached are two diff patches. One to patch your
SlackBuild script to patch and build Stellarium 0.13.3 and the other patch
is the Gentoo patch that will allow for building against qt-5.5. The
changes to your SlackBuild script will only apply Gentoo's qt-5.5 patch
only if $QT55 is set to 'YES'. I have it set to 'NO' by default just in
case someone has an earlier version of qt5 installed.


Eric Underhill

The two diff files are below:


--- stellarium.SlackBuild	2015-09-24 12:39:19.000000000 -0700
+++ stellarium-qt55.SlackBuild	2015-09-24 12:44:12.539867926 -0700
@@ -26,6 +26,9 @@
+# Change to 'YES' if building against qt55 otherwise Stellarium will fail to
+# build.

 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
@@ -68,6 +71,12 @@
   -o -perm 511 \) -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+#If building against qt55 apply patch to fix building against qt55
+if [ "$QT55" = "YES" ]; then
+  patch p1 < $PRGNAM-$VERSION.qt55.patch

 mkdir build && cd build
   cmake -DCMAKE_INSTALL_PREFIX=/usr \


diff -ur -x CMakeFiles -x Makefile -x 'CMake*'
--- src/CLIProcessor.hpp       2015-03-08 12:41:55.000000000 +0100
+++ src/CLIProcessor.hpp   2015-07-12 13:29:36.059179087 +0200
@@ -21,6 +21,7 @@

 #include <QStringList>
+#include <QVariant>

 class QSettings;

diff -ur -x CMakeFiles -x Makefile -x 'CMake*'
--- src/core/StelSkyCultureMgr.hpp     2015-03-08 12:41:55.000000000 +0100
+++ src/core/StelSkyCultureMgr.hpp 2015-07-12 13:28:32.589064791 +0200
@@ -23,6 +23,7 @@
 #include <QMap>
 #include <QString>
 #include <QStringList>
+#include <QObject>

 //! @class StelSkyCulture
 //! Store basic info about a sky culture for stellarium.

diff -ur -x CMakeFiles -x Makefile -x 'CMake*'
--- src/core/StelLocationMgr.cpp    2015-02-25 12:30:31 +0000
+++ src/core/StelLocationMgr.cpp    2015-03-03 14:34:38 +0000
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20151012/36ecbc85/attachment-0001.html>

More information about the SlackBuilds-users mailing list