[Slackbuilds-users] a bug+solution found on transcode Slackbuilds

matic maticsavli6 at gmail.com
Sun Apr 24 20:10:31 UTC 2016

On 04/24/2016 06:03 PM, Willy Sudiarto Raharjo wrote:
>> I would like to give some feedback on the
>> https://slackbuilds.org/repository/14.1/multimedia/transcode/
>> First thanks for providing this package.
>> Transcode build itself is perfectly fine but I found one bug using
>> transcode and ffmpeg mpeg2video codec
>> A command making me problems and the output log are attached below
>> (transcode_failed_log.txt). There is this pointer issue that was already
>> found on
>> https://bitbucket.org/france/transcode-tcforge/issues/4/segfault-at-end-of-pass-1-ffmpeg-mpeg4.
>> ffmpeg version used:
>>      ffmpeg version 2.1 Copyright (c) 2000-2013 the FFmpeg developers
>>    built on Apr 29 2014 18:30:44 with gcc 4.8.2 (GCC)
>>    configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64
>> --docdir=/usr/doc/ffmpeg-2.1/html --mandir=/usr/man --disable-debug
>> --enable-shared --disable-static --enable-pthreads --enable-libtheora
>> --enable-libvorbis --enable-gpl --enable-version3 --enable-postproc
>> --enable-swscale --enable-x11grab --enable-avfilter --enable-gnutls
>> --enable-libcdio --enable-libssh --arch=x86_64 --enable-libmp3lame
>> --enable-libx264
>> transcode version used:
>>      from https://slackbuilds.org/repository/14.1/multimedia/transcode/)
>>      transcode v1.1.7 (C) 2001-2003 Thomas Oestreich, 2003-2010 Transcode
>> Team
>> I add the correction (using
>> https://bitbucket.org/france/transcode-tcforge/issues/4/segfault-at-end-of-pass-1-ffmpeg-mpeg4)
>> for the command above to work in a patch (attached below). Along I
>> modified the transcode.SlackBuild to use this patch (also attached
>> below). It is important to first use this patch and then all others
>> already provided in the package.
>> This solved the problem. I hope you can modify the Slackbuild package
>> using this solution or just to let you know...
> Hi
> can you test using the latest ffmpeg and transcode in master branch?
> some changes have been merged in master branch and they are not
> backported to 14.1 branch anymore


Just tested your suggestion. I tried with the master branch ffmpeg and 
transcode. In ffmpeg I was forced to remove the following flags from the 
configure step to successfully compile:

|--enable-libopenjpeg ||--enable-libpulse ||--enable-libvpx|

For the transcode I was also forced to remove one flag:


and I used the following  to build (this is actually also applied in my 
previous email, but forget to mention):
LDFLAGS='-L/usr/lib64 -L/lib64'  MJPEGTOOLS=yes ./transcode.SlackBuild

So at the end the ffmpeg version:
ffmpeg version 2.8.6 Copyright (c) 2000-2016 the FFmpeg developers
   built with gcc 4.8.2 (GCC)
   configuration: --prefix=/usr --libdir=/usr/lib64 
--shlibdir=/usr/lib64 --docdir=/usr/doc/ffmpeg-2.8.6/html 
--mandir=/usr/man --disable-debug --enable-shared --disable-static 
--enable-pthreads --enable-libtheora --enable-libvorbis --enable-gpl 
--enable-version3 --enable-postproc --enable-swscale --enable-x11grab 
--enable-avfilter --enable-avresample --enable-gnutls --enable-libcdio 
--enable-libssh --enable-libcaca --enable-libsmbclient --enable-opengl 
--enable-libwavpack --enable-libfreetype --enable-libfribidi 
--enable-fontconfig --arch=x86_64

And transcode:
transcode v1.1.7 (C) 2001-2003 Thomas Oestreich, 2003-2010 Transcode Team

After all this the same command was tested but it failed the same way. I 
then used the patch I described in my previous email and the program 
finished successfully. I think that compile flags removed above 
shouldn't do much change here but I am not sure. What do you think?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20160424/254e9ab0/attachment-0001.html>

More information about the SlackBuilds-users mailing list