[Slackbuilds-users] libreoffice 5.1 review

Christoph Willing chris.willing at iinet.net.au
Fri Feb 12 12:10:18 UTC 2016

On 12/02/16 21:06, Willy Sudiarto Raharjo wrote:
>> Good news and ...
>> I tried using the SlackBuild in libreoffice-review with the ch3.ppt test
>> file and found no problem. I had it running several hours in the
>> background while doing other things. Occasionally I would flip through a
>> few pages and all was OK.
>> I also opened a test file mentioned in the first of the bug reports
>> above and it also worked without any problem.
>> The only problem I found was when opening a file provided by someone
>> else via the libreoffice-dev list. Interestingly, they claim that the
>> official downloaded version (I'm equating that with the repackaged
>> libreoffice-review version) loads and runs the test file fine but their
>> own self-compiled version loads the file very slowly (>10 sec.). A file
>> demonstrating the problem is provided at
>> https://bugs.documentfoundation.org/attachment.cgi?id=121623 .
>> I found that the version in libreoffice-review loads that file
>> (bigfile.odt) in 2-3secs but crashes immediately loading is complete.
>> This occurred 100% of the times I tried it. The new LibreOffice
>> build-from-source SlackBuild, which I have a personal interest in,
>> handles it OK - loads in 2-3secs and keeps running. Still, I'm not sure
>> what what to make of the test file - whether its a valid test of
>> anything - since it looks like gibberish when loaded.
>> BTW Calligra Author opens bigfile.odt OK (under 3 secs).
>> Not sure if that helps you decide anything but that is what I found.
> Hi Chris
> thanks for confirming, but i had this problem on my laptop and desktop
> and workstation, so it's not just happening on one machine.
> Also, Robby and i found this bug which is similar to my sympthoms
> https://crux.nu/bugs/index.php?do=details&task_id=1286
> just to make sure. Did you upgrade to the latest current with harfbuzz
> 1.1.3? It seems that's the culprit since Robby tried to downgrade to
> 1.1.2 and it worked nicely

chris at d6:~$ ls -l /var/log/packages/harfbuzz-1.1.3-x86_64-1
-rw-r--r-- 1 root root 5931 Feb  9 11:40 

More information about the SlackBuilds-users mailing list