[Slackbuilds-users] Community Challenge! Help fix the last few SlackBuilds for 14.2

David Spencer baildon.research at googlemail.com
Sun May 29 23:23:14 UTC 2016

Hey folks!

So here we all are, waiting for the release of Slackware 14.2. It's
looking good, but nobody knows when it will be good enough for Patrick

Meanwhile, work is continuing to get SlackBuilds.org ready for the new
release. According to Willy there have been 2373 commits in the SBo
git repo since submissions were closed.  That's about one commit every
1hour 20min. You can see Willy's list here:


At this time there are only a few packages that fail to build, and all
the git commiters are getting a bit tired, so we would like to
challenge the community to help fix the last few problems.  Your
reward will be a nice Thank You in the git repo :D

Here are the first four ... if you can fix them, there will be some more later!

1. academic/Xyce


It looks like an underlinking error, but I can't see anything wrong
with the link. There is a new version 6.4 upstream, I have tried it,
but the same linking problem happens.  Maybe its dep
libraries/trilinos is involved -- Guilherme (maintainer of both Xyce
and trilinos) downgraded trilinos soon after it was first added.  I
can't find any bug reports.  Most other distros don't have Xyce.

If you don't want to register to download the source, there is a copy
of Xyce-6.4 on SlackBuilds Direct Links (Xyce is GPL, so
redistributing it is perfectly legal ;)

2. development/hhvm


The problem is caused by changes in the latest glibc that are related
to std::isnan and std::isinf in c++. 3.11.0 is an old version, we
could try an upgrade but it's not clear whether newer versions fix the
problem.  Because hhvm uses a lot of git submodules, it's quite a lot
of work to add downloads, or to create and host a new repacked source

There was previously some discussion on this mailing list whether
anybody actually wants hhvm:

So, if anybody wants hhvm, you are welcome to fix it ;)

3. games/ember


The build was broken by the new version of sigc++. Upstream is quite
active but seems to have stopped tagging proper releases. I tried the
latest git, but it needs its deps also updating to compatible

and deps at https://github.com/worldforge

4. graphics/photivo


This looks like an underlinking error, but the build fails for me only
on x86_64 ... on i586 it builds ok!

That's all for now, if you have fixes for any of those you are welcome
to reply to this thread with patches or suggestions.

Thanks for your help and support!

More information about the SlackBuilds-users mailing list