[Slackbuilds-users] Updates - 20161231.1

Andrzej Telszewski atelszewski at gmail.com
Mon Jan 2 00:04:44 UTC 2017

On 01/01/17 00:40, Willy Sudiarto Raharjo wrote:
>>> python/python3: Updated for version 3.6.0.
>> I'm not entirely sure if the updated Python is the reason for borgbackup
>> failing to build, but it surely was building before.
>> Anyways, adding setuptools-scm as requirement for borgbackup allows for
>> successful build.
>> So, please add setuptools-scm to REQUIRES of borgbackup, or wait until I
>> push an updated version.
>> All this being said, thanks and happy new year ;-)
>> See you soon :-)
> Well, it's working fine here
> msgpack-python:
>   MD5SUM check for msgpack-python-0.4.8.tar.gz ... OK
>   Building package msgpack-python-0.4.8-x86_64-1_SBo.tgz ... OK
>   Installing package msgpack-python-0.4.8-x86_64-1_SBo.tgz ... OK
> lz4:
>   MD5SUM check for r131.tar.gz ... OK
>   Building package lz4-r131-x86_64-1_SBo.tgz ... OK
>   Installing package lz4-r131-x86_64-1_SBo.tgz ... OK
> python3:
>   MD5SUM check for Python-3.6.0.tar.xz ... OK
>   Building package python3-3.6.0-x86_64-1_SBo.tgz ... OK
>   Installing package python3-3.6.0-x86_64-1_SBo.tgz ... OK
> borgbackup:
>   MD5SUM check for borgbackup-1.0.7.tar.gz ... OK
>   Building package borgbackup-1.0.7-x86_64-1_SBo.tgz ... OK
>   Installing package borgbackup-1.0.7-x86_64-1_SBo.tgz ... OK

I tried building the packages by hand (i.e. without any help of any 
tool) and it indeed succeeded.

Then I tried again using slackrepo and that's what I get:

Download error on https://pypi.python.org/simple/setuptools_scm/: [Errno 
-3] Temporary failure in name resolution -- Some packages may not be found!
Download error on https://pypi.python.org/simple/setuptools-scm/: [Errno 
-3] Temporary failure in name resolution -- Some packages may not be found!
Couldn't find index page for 'setuptools_scm' (maybe misspelled?)
Download error on https://pypi.python.org/simple/: [Errno -3] Temporary 
failure in name resolution -- Some packages may not be found!
No local packages or working download links found for setuptools_scm>=1.7
Traceback (most recent call last):
   File "setup.py", line 278, in <module>
   File "/usr/lib64/python3.6/distutils/core.py", line 108, in setup
     _setup_distribution = dist = klass(attrs)
   File "/usr/lib64/python3.6/site-packages/setuptools/dist.py", line 
315, in __init__
   File "/usr/lib64/python3.6/site-packages/setuptools/dist.py", line 
361, in fetch_build_eggs
   File "/usr/lib64/python3.6/site-packages/pkg_resources/__init__.py", 
line 850, in resolve
     dist = best[req.key] = env.best_match(req, ws, installer)
   File "/usr/lib64/python3.6/site-packages/pkg_resources/__init__.py", 
line 1122, in best_match
     return self.obtain(req, installer)
   File "/usr/lib64/python3.6/site-packages/pkg_resources/__init__.py", 
line 1134, in obtain
     return installer(requirement)
   File "/usr/lib64/python3.6/site-packages/setuptools/dist.py", line 
429, in fetch_build_egg
     return cmd.easy_install(req)
line 659, in easy_install
     raise DistutilsError(msg)
distutils.errors.DistutilsError: Could not find suitable distribution 
for Requirement.parse('setuptools_scm>=1.7')

I don't know why this error occurs, but anyways, maybe it's a signal 
that setuptools-scm should be actually in the REQUIRES?

Why the hell the install script tries to download anything?

Best regards,
Andrzej Telszewski

More information about the SlackBuilds-users mailing list