[Slackbuilds-users] tightvnc compile problems

Jim Diamond Jim.Diamond at acadiau.ca
Fri Jan 13 01:31:00 UTC 2017

On Fri, Jan 13, 2017 at 08:17 (+0700), Willy Sudiarto Raharjo wrote:

>> Thanks for the suggestions.

>> (1) The sum checks out.

>> (2) And I have

>> .../slackware64-14.2/slackware64/x/xorg-cf-files-1.0.6-x86_64-2.txz
>> .../slackware64-14.2/slackware64/x/xorg-docs-1.7.1-noarch-1.txz
>> .../slackware64-14.2/slackware64/x/xorg-server-1.18.3-x86_64-2.txz
>> .../slackware64-14.2/slackware64/x/xorg-server-xephyr-1.18.3-x86_64-2.txz
>> .../slackware64-14.2/slackware64/x/xorg-server-xnest-1.18.3-x86_64-2.txz
>> .../slackware64-14.2/slackware64/x/xorg-server-xvfb-1.18.3-x86_64-2.txz
>> .../slackware64-14.2/slackware64/x/xorg-sgml-doctools-1.11-x86_64-2.txz

>> in my copy of slackware, and   dir /var/log/packages/xorg-*   says

>> /var/log/packages/xorg-cf-files-1.0.6-x86_64-2
>> /var/log/packages/xorg-docs-1.7.1-noarch-1
>> /var/log/packages/xorg-server-1.18.3-x86_64-2
>> /var/log/packages/xorg-server-xephyr-1.18.3-x86_64-2
>> /var/log/packages/xorg-server-xnest-1.18.3-x86_64-2
>> /var/log/packages/xorg-server-xvfb-1.18.3-x86_64-2
>> /var/log/packages/xorg-sgml-doctools-1.11-x86_64-2

>> So that all looks OK.

> It it possible to attach the complete build log?

It is.  And I still can, if you want (just let me know).

But it occurred to me that perhaps this is one of those packages that
won't build if you give -j <something bigger than 1> as a make option.

So I tried with -j 1
        sboconfig -j 1 ; sboinstall tightvnc
And it worked this time.

(If God didn't want me to have 8 compiles going at one time, He
wouldn't have let me have a computer with 4 hyper-threaded cores.)

So maybe I should rephrase my issue here as follows:
        Should we put a note in the README that says to use "-j 1" for
        best results?



More information about the SlackBuilds-users mailing list