[Slackbuilds-users] egoboo?

David Melik davidnchmelik at gmail.com
Sun May 21 07:23:55 UTC 2017

On 05/20/2017 09:26 PM, David Melik wrote:
> On 05/20/2017 12:56 PM, Willy Sudiarto Raharjo wrote:
>>> David Melik 
>>> <davidnchmelik-Re5JQEeQqe8AvxtiuMwx3w-XMD5yJDbdMReXY1tMh2IBg at public.gmane.org> 
>>> wrote:
>>>> I'd like to try egoboo on Slackware64 14.2 but egoboo has a
>>>> segmentation fault...
>>> I'm sending this to the -users list in hopes that someone might be
>>> willing to take over maintenance. The version in the repo is outdated,
>>> which might be the problem. I tried to simply bump it to 2.8.1 but it
>>> seems the steps to build it have changed and I'm not really set up to
>>> troubleshoot that right now.
>>> If anyone is willing to take over, please feel free and submit a new
>>> version. Thanks!
>> Hi David
>> can you try this changes?
>> https://git.slackbuilds.org/slackbuilds/log/?h=egoboo-review
> d at cosmos:~/egoboo$ sudo egoboo.SlackBuild
> [...]
> patching file src/game/game.c
> Hunk #1 FAILED at 2052 (different line endings).
> 1 out of 1 hunk FAILED -- saving rejects to file src/game/game.c.rej
> d at cosmos:~/egoboo$

I don't normally report something until I've seen it a couple/few times. 
I changed that line to the below.

   patch --binary -p1 < $CWD/keyboard_directions.patch

Then the exact same thing (same file, same error and place) happened.

More information about the SlackBuilds-users mailing list