[Slackbuilds-users] Library versions need to be upgraded

Rich Shepard rshepard at appl-ecosys.com
Sat Sep 2 01:52:02 UTC 2017

On Fri, 1 Sep 2017, Robby Workman wrote:

> I'd almost bet dollars to donuts that gnucash is trying to link to a
> library that is linked to that libsomething.so.56, but since the
> libsomething.so.56 is not present any more, the link is failing.


   It's the opposite. Gnucash wants libicuil18n.so.51 (which was used in the
prior gnucash) while libicuil18n.so.56 is in the current webkitgtk package.

> Given that the libsomething.so.56 or whatever it was is newer than
> what is in the SBo repo, it's probably an artifact from when you
> were trying newer versions of stuff,

   It's not in the SBo repo under webkitgtk, but is there in webkit2gtk.
That's what I learned from Didier this afternoon. The only 'newer' version
I need to get running is gnucash-2.6.17 because the 14.2 upgrade did not
load 2.6.16 (library version difference).

   If there is something subtle here that needs cleaning, as there seems to
be, I want to find it and clean it out. There are no duplicates in of /usr
in /usr/local so it must be elsewhere.


More information about the SlackBuilds-users mailing list