[Slackbuilds-users] long-time build errors (open-adventure, notepadqq, sbocheck of adobe-reader & VariCAD)

Matteo Bernardini matteo.bernardini at gmail.com
Tue Aug 7 05:37:34 UTC 2018

2018-08-07 6:57 GMT+02:00 David Melik <davidnchmelik at gmail.com>:
> Notepadqq won't work when there's a libwebp version after 0.5.n, though not
> a dependency (and not dependency of a dependency?)  The maintainer said
> recompile with a new libwebp.  I did, then notepadqq wouldn't run, and I
> notified him, but didn't hear back (months ago.)  People need libwebp
> updated for other SBo packages, so we can't have 'dependency Hell' starting.
> I have adobe-reader and sbocheck always says it has to be rebuilt as 9.5.5
> rather than the current 9.5.5_enu.
> I have VariCAD and and sbocheck always says it has to be rebuilt for
> 2013_2.01 rather than the current 2013_2.01_en.
> I get this error compiling open-adventure (for months.)
>    cc -std=c99 -D_DEFAULT_SOURCE -DVERSION=\"1.4\" -O2 -fPIC
>    -D_FORTIFY_SOURCE=2 -fstack-protector-all  -o advent main.o init.o
>    actions.o score.o misc.o saveresume.o dungeon.o  -ledit -lncurses
>    a2x --doctype manpage --format manpage advent.adoc
>    ERROR: advent.adoc: line 1: malformed manpage title
>    ERROR: advent.adoc: line 4: first section must be named NAME
>    ERROR: advent.adoc: line 7: second section must be named SYNOPSIS
>    a2x: failed: asciidoc --doctype=manpage  -d manpage -b docbook
>    "advent.adoc"
>    Makefile:68: recipe for target 'advent.6' failed
>    make: *** [advent.6] Error 1

Hi David,

I've just tried building open-adventure and its dependencies (libedit
ad PyYAML) here on a clean and full installation of slackware64-14.2
and I don't have the error you got when a2x (part of linuxdoc-tools)
processes its man page.

I'm now trying a build of notepadqq and all of its dependencies,
having previously installed libwebp, but it will take a little:
libwebp it's an optional dependency of qt5-webkit, so I thought that
building all of the notepadqq dependencies from scratch might help.

I can't answer about sbocheck because I never used it.


P.S. I've tried on stable because that's the supported platform, I
don't know if you're running current.

More information about the SlackBuilds-users mailing list