[Slackbuilds-users] vlc fails

Christoph Willing chris.willing at iinet.net.au
Sun Feb 18 00:47:21 UTC 2018

On 18/02/18 02:10, Willy Sudiarto Raharjo wrote:
>> /tmp/SBo/vlc-3.0.0/bin/.libs/lt-vlc-cache-gen: symbol lookup error: /usr/lib/libvtkCommonDataModel.so.1: undefined symbol: _ZN49vtkInformationQuadratureSchemeDefinitionVectorKeyD1Ev
>> Makefile:1789 : la recette pour la cible « ../modules/plugins.dat » a échouée
>> make[2]: *** [../modules/plugins.dat] Erreur 127
>> make[2] : on quitte le répertoire « /tmp/SBo/vlc-3.0.0/bin »
> Hi
> Have you tried to rebuild all vlc dependencies?

About vlc dependencies - I have seen this particular error and believe
it is due to vlc building with optional opencv support (and opencv is
built with VTK support - the default). It (vlc) certainly builds OK when
opencv if _not_ present at build time.

Alternatively, opencv could be built without VTK support:
    CVVTK=no sh opencv.SlackBuild
although I haven't tried this since I think VTK is probably more
valuable to opencv's functionality than opencv is to vlc's functionality.

I'll investigate this further during the coming week.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180218/9d1d627c/attachment.asc>

More information about the SlackBuilds-users mailing list