[Slackbuilds-users] Atom 1.23.3 fails to build

Daniel Prosser dpross1100 at msn.com
Sun Jun 3 22:52:52 UTC 2018

One correction - I changed the default $TAG and $TMP in the SlackBuild for my own build and forgot to change them back before creating the patch. Please disregard those changes.

From: SlackBuilds-users <slackbuilds-users-bounces at slackbuilds.org> on behalf of Daniel Prosser <dpross1100 at msn.com>
Sent: Sunday, June 3, 2018 6:45 PM
To: slack.dhabyx at gmail.com
Cc: slackbuilds-users at slackbuilds.org
Subject: [Slackbuilds-users] Atom 1.23.3 fails to build


I am unable to build Atom 1.23.3 on Slackware64 14.2. While it is
generating API docs, memory usage goes out of control until the build is
aborted. Apparently I am not alone, based on this thread:


Atom Installation - FATAL ERROR: CALL_AND_RETRY_LAST ...<https://www.linuxquestions.org/questions/slackware-14/atom-installation-fatal-error-call_and_retry_last-allocation-failed-javascript-heap-out-of-memory-4175628885/>
Hello, tried to install the Atom text editor. I did that via sboui (sbopkg). The two build options i set: Code: DISABLE_METRICS=yes DELETE_CACHE=yes I

I found an issue on Github related to this problem, which was resolved
after the 1.23.3 release:


Based on that information, I tried building 1.27.2 instead, and it
worked without issue; all I did was change the version number. So can we
get atom updated to that version? A patch is attached, though it is
quite trivial. I did make one small change to the .desktop file,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180603/4ee82a99/attachment-0001.html>

More information about the SlackBuilds-users mailing list