[Slackbuilds-users] system/lsyncd requires Lua 5.2
matteo.bernardini at gmail.com
Tue Mar 20 20:11:35 UTC 2018
2018-03-20 20:46 GMT+01:00 Arkadiusz Drabczyk <arkadiusz at drabczyk.org>:
> A new release of lsyncd requires at least Lua 5.2, in ChangeLog
> https://github.com/axkibe/lsyncd/blob/master/ChangeLog it says:
> change: needing now at least Lua 5.2 (Lua 5.1 no longer supported, Lua5.3 supported)
> We used to have Lua 5.2 but it was removed in commit 9389d02 'until a
> working way to manage multiple lua versions in the system is
> provided'. Moreover, development/lua README says:
> "This package is for the version 5.1.x of lua, the one compatible with
> the software that needs lua on slackbuilds.org."
> Lua 5.1 line is really quite old, the oldest release was on 17 Feb
> 2012 according to this site https://www.lua.org/versions.html. I
> counted 66 packages that require lua:
> find . -name "*.info" | xargs grep "^REQUIRES.*\blua\b" | wc -l
> It would require a lot of manual work to check if all of these
> packages could work with Lua 5.2. Should I just wait and explain that
> system/lsyncd would not be upgraded until Lua 5.2 becomes the default?
I don't think that lua will become the default, as many scripts still
the ideal should be to have versioned versions of lua (like lua51,
lua52, lua53, etc.) all parallel-installable together so that whatever
needs one specific version could use it but this is not made easy by
the upstream lua developers.
if you (or whoever else) feel like to submit a new lua52.SlackBuild,
as a dependency of lsyncd, that will be parallel installable with the
lua we have, you are welcome: if you want/need you can also modify the
lua.SlackBuild that we have in our repository (you can even take
maintainership, if you prefer), taken that it will still play fine
with what we have in our repository.
More information about the SlackBuilds-users