[Slackbuilds-users] system/lsyncd requires Lua 5.2

Willy Sudiarto Raharjo willysr at slackbuilds.org
Sat Mar 31 01:19:38 UTC 2018

> A new release of lsyncd requires at least Lua 5.2, in ChangeLog
> https://github.com/axkibe/lsyncd/blob/master/ChangeLog it says:
> change: needing now at least Lua 5.2 (Lua 5.1 no longer supported, Lua5.3 supported)
> We used to have Lua 5.2 but it was removed in commit 9389d02 'until a
> working way to manage multiple lua versions in the system is
> provided'.  Moreover, development/lua README says:
> "This package is for the version 5.1.x of lua, the one compatible with
> the software that needs lua on slackbuilds.org."
> Lua 5.1 line is really quite old, the oldest release was on 17 Feb
> 2012 according to this site https://www.lua.org/versions.html.  I
> counted 66 packages that require lua:
> find . -name "*.info" | xargs grep "^REQUIRES.*\blua\b" | wc -l
> It would require a lot of manual work to check if all of these
> packages could work with Lua 5.2.  Should I just wait and explain that
> system/lsyncd would not be upgraded until Lua 5.2 becomes the default?

we now have lua52/53 in the repo, so you can start testing it with newer lua

Willy Sudiarto Raharjo

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20180331/9c2d4398/attachment.asc>

More information about the SlackBuilds-users mailing list