[Slackbuilds-users] Odd Directory Name in OpenSceneGraph-3.5.5.tar.gz

Christoph Willing chris.willing at linux.com
Sun May 27 02:46:34 UTC 2018

On 27/05/18 10:25, Christoph Willing wrote:
> On 27/05/18 05:46, Konrad J Hambrick wrote:
>> Here is another one ... I had the OPTIONAL Package
>> fltk-1.3.3-x86_64-2_SBo.tgz installed for the flSynclient Package.
>> It turns out that OpenSceneGraph will build example_osgviewerFLTK if
>> FLTK is installed.
>> However it fails for fltk-1.3.3.
>> Here is the tail of my build log:
>> Scanning dependencies of target example_osgviewerFLTK
>> [100%] Building CXX object
>> examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/osgviewerFLTK.cpp.o
>> [100%] Linking CXX executable ../../bin/osgviewerFLTK
>> /usr/lib64/gcc/x86_64-slackware-linux/5.5.0/../../../../lib64/libfltk_gl.so:
>> undefined reference to `Fl_XFont_On_Demand::value()'
>> collect2: error: ld returned 1 exit status
>> examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/build.make:123:
>> recipe for target 'bin/osgviewerFLTK' failed
>> make[2]: *** [bin/osgviewerFLTK] Error 1
>> CMakeFiles/Makefile2:18128: recipe for target
>> 'examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/all' failed
>> make[1]: ***
>> [examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/all] Error 2
>> Makefile:127: recipe for target 'all' failed
>> make: *** [all] Error 2
>> I upgraded FLTK to version 1.3.4-2 ( yes ... it is 'dash 2' ) and
>> OpenSceneGraph compiled and installed and runs properly now.
> I thought I'd covered all the bases before updating the OSG version but
> missed this one (obviously!). I'll look at it during the week.

Actually, I can't replicate this problem. In a clean VM with newly built
/var/log/packages/fltk-1.3.3-x86_64-2 installed I see:

Scanning dependencies of target example_osgviewerFLTK
[ 80%] Building CXX object
[ 81%] Linking CXX executable ../../bin/osgviewerFLTK
[ 81%] Built target example_osgviewerFLTK

If I run (still in the VM so with limited GL capability) the command:
    strings /usr/lib64/libfltk_gl.so.1.3 |less
and search for XFont, I see a single reference:

In a real machine with Nvidia graphics and binary driver, the same
search reveals:

Seeing that difference in varying graphics environments (although
compilation continues to completion in both these particular cases) I
wonder if the issue you're seeing is due to your (perhaps even more
different) graphics environment (Intel, nouveau, ...)? That wouldn't
necessarily explain why it worked for you with updated fltk though. Or,
maybe your fltk-1.3.3 was built some time ago - _before_ you updated
your graphics hardware/driver (so failed) but your fltk-1.3.4-2
succeeded because you just built it now using the updated graphics

Anyway, I'll email the fltk maintainer and ask if he's prepared to
upgrade the version. My stored source tarball fltk-1.3.3-source.tar.gz
is dated Nov 4 2014 i.e. it's a pretty old version. However fltk seems
to have a ton of dependent SlackBuilds so checking all of them with a
newer fltk won't be trivial.


More information about the SlackBuilds-users mailing list