[Slackbuilds-users] Odd Directory Name in OpenSceneGraph-3.5.5.tar.gz

Christoph Willing chris.willing at iinet.net.au
Sun May 27 07:31:10 UTC 2018

On 27/05/18 12:46, Christoph Willing wrote:
> On 27/05/18 10:25, Christoph Willing wrote:
>> On 27/05/18 05:46, Konrad J Hambrick wrote:
> [snip]
>>> Here is another one ... I had the OPTIONAL Package
>>> fltk-1.3.3-x86_64-2_SBo.tgz installed for the flSynclient Package.
>>> It turns out that OpenSceneGraph will build example_osgviewerFLTK if
>>> FLTK is installed.
>>> However it fails for fltk-1.3.3.
>>> Here is the tail of my build log:
>>> Scanning dependencies of target example_osgviewerFLTK
>>> [100%] Building CXX object
>>> examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/osgviewerFLTK.cpp.o
>>> [100%] Linking CXX executable ../../bin/osgviewerFLTK
>>> /usr/lib64/gcc/x86_64-slackware-linux/5.5.0/../../../../lib64/libfltk_gl.so:
>>> undefined reference to `Fl_XFont_On_Demand::value()'
>>> collect2: error: ld returned 1 exit status
>>> examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/build.make:123:
>>> recipe for target 'bin/osgviewerFLTK' failed
>>> make[2]: *** [bin/osgviewerFLTK] Error 1
>>> CMakeFiles/Makefile2:18128: recipe for target
>>> 'examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/all' failed
>>> make[1]: ***
>>> [examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/all] Error 2
>>> Makefile:127: recipe for target 'all' failed
>>> make: *** [all] Error 2
>>> I upgraded FLTK to version 1.3.4-2 ( yes ... it is 'dash 2' ) and
>>> OpenSceneGraph compiled and installed and runs properly now.
>> I thought I'd covered all the bases before updating the OSG version but
>> missed this one (obviously!). I'll look at it during the week.
> Actually, I can't replicate this problem. In a clean VM with newly built
> /var/log/packages/fltk-1.3.3-x86_64-2 installed I see:
> Scanning dependencies of target example_osgviewerFLTK
> [ 80%] Building CXX object
> examples/osgviewerFLTK/CMakeFiles/example_osgviewerFLTK.dir/osgviewerFLTK.cpp.o
> [ 81%] Linking CXX executable ../../bin/osgviewerFLTK
> [ 81%] Built target example_osgviewerFLTK
> If I run (still in the VM so with limited GL capability) the command:
>     strings /usr/lib64/libfltk_gl.so.1.3 |less
> and search for XFont, I see a single reference:
>     glXUseXFont
> In a real machine with Nvidia graphics and binary driver, the same
> search reveals:
>     _ZN18Fl_XFont_On_Demand5valueEv
>     glGenLists
>     glXUseXFont
> Seeing that difference in varying graphics environments (although
> compilation continues to completion in both these particular cases) I
> wonder if the issue you're seeing is due to your (perhaps even more
> different) graphics environment (Intel, nouveau, ...)? That wouldn't
> necessarily explain why it worked for you with updated fltk though. Or,
> maybe your fltk-1.3.3 was built some time ago - _before_ you updated
> your graphics hardware/driver (so failed) but your fltk-1.3.4-2
> succeeded because you just built it now using the updated graphics
> hardware/driver.
> Anyway, I'll email the fltk maintainer and ask if he's prepared to
> upgrade the version. My stored source tarball fltk-1.3.3-source.tar.gz
> is dated Nov 4 2014 i.e. it's a pretty old version. However fltk seems
> to have a ton of dependent SlackBuilds so checking all of them with a
> newer fltk won't be trivial.

Just as well I did some more checking before emailing the maintainer. It
turns out that the SBo fltk is excess to requirements since there is
already an fltk package in stock Slackware's extra. I guess that means
the version in extra won't be updated. However the version at SBo is a
mystery - from the git log it seems to be renamed some time ago from
fltk13 but I don't understand why it still exists at all now that we
have the fltk in extra.

I see from your original email that you were using an SBo build
(fltk-1.3.3-x86_64-2_SBo.tgz). I wonder if your OpenSceneGraph would
succeed if you removed that version and installed the version from
extra? I guess you're happy anyway having upgraded your local fltk and
built OSG with that but it would be nice to know whether you could build
it with the fltk from extra (as it does here).


More information about the SlackBuilds-users mailing list