[Slackbuilds-users] KMyMoney 4.8.4 breaks Print to File

cnguyenminhtan at free.fr cnguyenminhtan at free.fr
Thu Sep 26 07:30:40 UTC 2019


I can reproduce the lack of PDF file when printing on Slackware64 14.2 
fully patched with kmymoney 4.8.4 built using SlackBuilds.org script.
After the printing windows is closed, nothing happens. There is no file 
created when I said it should and an error message.

I don't have a printer available to check if printing to printer works.

I don't use printing with kmymoney so I cannot say whether it worked in 
the previous version.

Hope this helps.

Christophe Nguyen

Le 2019-09-24 15:21, Erich Ritz a écrit :
> Upgrading to KMyMoney 4.8.4 breaks the "Print to File (PDF)" feature
> for me when printing report tables.
> Upstream told me to take it up with my distribution:
> https://bugs.kde.org/show_bug.cgi?id=405061#c5
> Can anybody else reproduce?  If so, I'll open a new bug report
> upstream.  My original report was a comment to an existing issue,
> since I was able to track the problem to a specific commit.
> I'm using 64-bit Slackware 14.2.  It's not explicitly mentioned below,
> but I can reproduce the issue on 2 different computers.
> Here was my original bug report:
> Commit 15ac7d472af41fc503dc5209643cfc8b392b0089 breaks "Print to PDF" 
> for me.
> I noticed after upgrading to 4.8.4 that "Print to File (PDF)" no
> longer worked for printing report tables.  Doing a git bisect, I
> learned that 15ac7d472 "Add print support for report charts" is what
> broke "Print to File (PDF)".  Reverting this commit on top of branch
> 4.8 (HEAD was at 0ae5377fd "Fix reverse sort order handling in
> register" at time of testing) restored "Print to PDF" functionality
> for me.
> I am using Slackware64 14.2 (latest stable version of Slackware
> 64-bit, with all patches installed).  KMyMoney was compiled using the
> build script from
> https://slackbuilds.org/repository/14.2/office/kmymoney/
> Steps to reproduce:
> Choose Reports, 1. Income and Expenses -> Income and Expenses This
> Month (Default Report)
> Then choose Print, Print to File (PDF).
> 4.8.4 fails to create the PDF (but it does ask for confirmation when
> trying to overwrite an existing PDF).
> It gets weirder, though: on my home laptop, choosing the "Print to
> File (PDF)" option actually sends the job to my physical printer.
> This caused me to burn through a lot of paper, because the printer is
> in a different room, and I didn't realize it was printing...

More information about the SlackBuilds-users mailing list