[Slackbuilds-users] thunarx-python and lots of hoops to jump through

Peter Dambier peter at peter-dambier.de
Sat Jan 25 19:09:37 UTC 2020

It all begun with an error message about thunarx-2 missing and thunarx-1
not found.

That is why I tried Python/thunarx-python in the first place but it got
me the same error message.

I downloaded thunarx-python-0.5.1 from the same source and adjusted the
version in the slackbuild. It got me


Slackware package /tmp/thunarx-python-0.5.1-i486-1_SBo.tgz created.

but did not cure the thunar plugins, not completely at least.

Next I cloned

  git clone https://github.com/xfce-mirror/thunar-archive-plugin.git

I renamed the resulting directory to


I had to

run autogen.sh

and ignore that .configure was run automatically.

I had to

touch thunar-archive-plugin-0.4.0/.changelog.tmp

or make would not complete.


tar zcvf thunar-archive-plugin-0.4.0.tar.bz2 thunar-archive-plugin-0.4.0

and adjusting the version string in thunar-archive-plugin.SlackBuild

I got

WARNING:  zero length file usr/doc/thunar-archive-plugin-0.4.0/ChangeLog

Slackware package /tmp/thunar-archive-plugin-0.4.0-i486-1_SBo.tgz created.

I did install my new thunar-archive-plugin-0.4.0-i486-1_SBo.tgz and
thunar actually does display the SBo.tgz.

Not for the faint of heart but it can be done and I hope I have given a
hint to the maintainers.

I have seen other distros scratching their heads as well.

Cheers and a Hapy New Year - in China today the Year of the Metal Rat
has begun.

Peter and Karin Dambier
Adalbert-Stifter-Strasse 17
D-69509 Moerlenbach
+49(6209)280-3030 (VoIP: GGEW)
+49(6252)750-308 (VoIP: sipgate.de)
mail: peter at peter-dambier.de

More information about the SlackBuilds-users mailing list