[Slackbuilds-users] Updates - 20201107.1

Marek Wodzinski majek at w7i.pl
Sat Nov 14 20:51:15 UTC 2020


I had also recently some Intel related problems with Chromium (Alien's 
build) and also Opera. I didn't test Vivaldi, but it's also 
Chromium based.
I think that there were some changes in Chromium engine which broke all 
these browsers on Intel cards.
Browsers started ok, but full-screen didn't work and after some use of 
GL, application stopped redraw itself (it worked and responded to my 
clicks, but nothing changed on screen). I tried kernel upgrade (nothing 
changed), Mesa upgrade (Mesa 13.0.6 can be built on stock 14.2) - i have 
a feeling that this made things little better. Of course I tried 
disabling hardware acceleration in browser and it helped a 
lot, but in long term it didn't fixed issue.

What fixed in my setup was creating configuration for Intel card for X11 
(maybe together with new Mesa, but I didn't try to downgrade it) in 
/etc/X11/xorg.conf.d/20-intel.conf to force enabling DRI 3:
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "DRI"    "3"

Best regards,
"If you want something done...do yourself!"
Jean-Baptiste Emmanuel Zorg

On Tue, 10 Nov 2020, Spycrowsoft wrote:

> Hello,
> I can confirm that I had a similar experience with Vivaldi.
> Except in my case, the profile folder had been mutilated to such an extent by 
> the new version that even the previous version of Vivaldi would just crash 
> and burn when I tried to start it.
> Starting over with a clean profile folder and hardware acceleration disabled 
> was easy because I'm using the sync feature.
> I've tried re-enabling hardware acceleration afterwards, which lead to the 
> same result.
> I've also been running the latest versions of Vivaldi on SBo with hardware 
> acceleration disabled on Slackware 14.2 without any issues since then.
> For what it's worth: I've seen the same thing happening on a system with 
> NVIDIA Optimus disabled, and a system which only has an Intel embedded 
> graphics card. So it seems to be some kind of Intel-related issue.
> Given that this is a pretty common setup, it might be feasible to make a note 
> of this in the README file, or even to take precautions in the 
> slackbuild-script itself.
> However, given that the general philosophy of Slackware is to assume that the 
> user is smart and that other hardware configurations are not guaranteed to 
> fail, such precautions should be optional.
> Therefore I think that a note in the README and a variable that can 
> optionally be set to apply your fix directly from the slackbuild with 
> something like "DEFAULT_DISABLE_GPU_ACCELERATION=yes ./vivaldi.Slackbuild", 
> might be the most elegant solution here.
> Kind regards,
> Spycrowsoft
> Op 10-11-2020 om 01:55 schreef Luiz Carlos Ramos via SlackBuilds-users:
>>  Hello,
>>  just posting about a thing that happened here with vivaldi (the
>>  browser).
>>  When it was first upgraded to version 3.4, it became broken due to some
>>  anoying problems with the GUI (windows seemed to be opened but didn't
>>  react to mouse clicks; minimizing the window seemed to work but the
>>  screen didn't change, etc.).
>>  At that time I went back to the version 2022.47 (from the end of
>>  Setember and the last one from 3.3 series) and it ran flawlessly again.
>>  This happened again for two or three times, for each slackbuild version
>>  posted so far in the 3.4 series.
>>  Last week (in another frustating upgrade) I tried to investigate a
>>  little bit more about this and ultimately found an answer in one post on
>>  this thread:
>>  https://forum.vivaldi.net/topic/52242/vivaldi-3-4-freezes-constantly-debian-10-intel-gpu/9,
>>  which is to run vivaldi from the CLI this way:
>>     $ vivaldi --disable-gpu-compositing
>>  another way to solve the problem is to disable GPU acceleration in the
>>  settings page (but to do this one must bring to the "settings" screen,
>>  which seems to be impossible when the problem happens).
>>  Here I managed to change /usr/bin/vivaldi inserting that option
>>  hardcoded in the shell script which starts the real vivaldi binary. This
>>  way I can run vivaldi from the GUI as well.
>>  The issue seems to be related to the specifics of the GPU used and I
>>  would not risk talking about it as it seems to require a deep knowledge of
>>  the inner bits.
>>  A curiosity of mine is if anybody else has experienced such problem.
>>  Anyway (and supposing this isn't a problem specific of myself), a
>>  suggestion would be writing some notes in the README file about it. I
>>  would volunteer doing so if there are no objections.
>>  Many thanks,
>>  Luiz Carlos Ramos
>>  Sao Paulo - Brazil
>>  lramos dot prof at yahoo dot com dot br

More information about the SlackBuilds-users mailing list