[Slackbuilds-users] naming conventions
fsLeg
fsleg at t-rg.ws
Sat Mar 8 19:31:52 UTC 2025
On 08.03.2025 20:31, kind.note8582 at fastmail.com wrote:
>why don’t we adopt a consistent naming approach like this:
>
> - kubectl.SlackBuild (compiles from source)
> - kubectl-bin.SlackBuild (repacks prebuilt binaries)
This question was actually raised a few days ago in a thread about a
proposed SlackBuild template for packaging pre-built binaries. It also
proposed to name scripts for repackaging software as *-bin, and in the
following discussion I felt that the consensus was to use exactly that
naming scheme for SlackBuilds, except for cases when repackaging a
binary is the only SBo-compatible way (like proprietary software).
So you should ask the current maintainer of kubectl to rename the
SlackBuild to kubectl-bin or even remove it altogether if building from
source doesn't require many dependencies and not resource-intensive.
More information about the SlackBuilds-users
mailing list