[Slackbuilds-users] Slack 12 libgnomecups pkg has no more than a docs folder

Martin Lefebvre dadexter at sekurity.com
Sat Sep 29 04:47:02 UTC 2007

On Fri, Sep 28, 2007 at 08:54:16PM -0700, Alan C wrote:

> > your paths might be foobared... do you have any files when you ls
> > /usr/lib/libcups*?
> root at AB60R:/home/al/install/pkgs_sw12/abiword_n_dep_libs# ls
> /usr/lib/libcups*
> /usr/lib/libcups.so.2*  /usr/lib/libcupsimage.so.2*
> root at AB60R:/home/al/install/pkgs_sw12/abiword_n_dep_libs#

I have 4 files:
/usr/lib/libcups.so    /usr/lib/libcupsimage.so
/usr/lib/libcups.so.2  /usr/lib/libcupsimage.so.2

you are missing libcups.so and libcupsimage.so.

the ones you have missing are symlinks... as I'm pretty sure you don't run
ls in a way to not display symlinks, I would recommend reinstalling cups,
just so the symlinks are created properly

> Maybe it doesn't like a certain kind of ions that are in the air near my
> computer :-)

it might... do you have any windows CDs or partitions around? the viruses
and bugs could be airborne :P

> ftp://slackware.mirrors.tds.net/pub/slackware/slackware-12.0/slackware/a/cups-1.2.11-i486-1.tgz
> I just DL that cups pkg and looked inside it.  I also used pkgtool to look
> at the cups on my sys.  They look the same.  I don't detect any difference.
> It appears that nothing is wrong with my cups.

the symlinks you "appear" to be missing wouldn't show in the package, they
are created by the doinst.sh file as part of the package installation

> I just DL and installed Robby's Abiword and dependencies packages.  Abiword
> works fine (not yet tried to print via Abiword).  Again, printing works fine
> from Kword and Firefox as well as the print a test page from within cups
> itself (3 ways that I've printed so far).
> I don't need to build *everything*.

true, but if you want it to work fine, and know what's being done to your
system, you might want to (that's just a bad generalization, RW's packages
are excellent).

> If there's any more that I can do, let me know.  Problem solved, I used
> someone else's packages.

Robby correct me if I'm wrong, but your packages are built from the same
SlackBuilds I had submitted, no?

Technically, once a binary is linked on a "working system", the fact that
some symlinks are missing might not be an issue... but they might be
required for the linking process when you try to compile the program.

so, to answer your original question, it's something specific to your box.

More information about the Slackbuilds-users mailing list