[Slackbuilds-users] ffmpeg

Robby Workman rworkman at slackbuilds.org
Fri Dec 26 06:47:32 UTC 2008

Please don't hijack unrelated threads :)

On Thu, 25 Dec 2008 22:40:59 -0800 (PST)
Darrell Anderson <humanreadable at yahoo.com> wrote:

> Hi Folks,
> I built ffmpeg. Initially the build script failed because I have /tmp
> mounted noexec. I'm not changing that. :-)


> The error message informed me that configure was looking for TMPDIR.
> I then ran the build script as follows:
> TMPDIR=/temporary/tmp/location ./ffmpeg.Slackbuild.
> That worked. I next modified the build script with:
> export TMPDIR=/temporary/tmp/location
> That worked too.
> Unlike all of the files I have built from SBo, the ffmpeg configure
> file is hard-coded to look for a TMPDIR environment variable, and if
> none is found defaults TMPDIR to /tmp.

Wow.  I'd expect that they would use TMP, and furthermore, I think that
should probably be mentioned to them.

> Perhaps a caution on the ffmpeg page might help? I realize most
> people mount /tmp executable, but a short caution would help those
> who don't.

Probably better to add something like this to the build script before
starting the compile process:
  export TMPDIR
and then "unset TMPDIR" after the compile process is finished.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20081226/2d3e03e4/attachment.asc>

More information about the SlackBuilds-users mailing list