[Slackbuilds-users] Help on creating my own local slackbuild repo at home

slakmagik slakmagik at gmail.com
Tue Jul 5 22:57:36 UTC 2011

On 2011-07-05 (Tue) 11:34:49 [-0400], Eric Schultz wrote:
> >
> >
> > ---------- Forwarded message ----------
> > From: "Ozan Türky?lmaz" <ozan.turkyilmaz at gmail.com>
> > To: "SlackBuilds.org Users List" <slackbuilds-users at slackbuilds.org>
> > Date: Tue, 5 Jul 2011 07:27:44 +0500
> > Subject: Re: [Slackbuilds-users] Help on creating my own local slackbuild
> > repo at home
> > 2011/7/5  <unix_lists at airpost.net>:
> >
> > git clone the SBo git repo. Add it to sbopkg repo files. after that
> > choose it at sbopkg repo config. When you change anything on the repo
> > do git add and git commit. When you a sbopkg -r (git pull) your
> > changes and repo changes will be merged nicely (depending on changes
> > you did).
> >
> I was trying to do something similar: I have a couple Slackware machines
> with similar setups so I wanted to have a central SBo repo.  I use the rsync
> backup on my NAS to sync SBo's repo but I can't seem to add it to the repo
> files!?  I tried to add it as a local repo at
> /media/network1/mirror/Sbo/build-13.37 but when ever I run sbopkg it says it
> doesn't exist and offers to create it for me?!

The default REPO_ROOT is /var/lib/sbopkg. The default REPO_NAME and
REPO_BRANCH are SBo and 13.37. At least for now, git repos (as opposed
to rsync) don't have REPO_BRANCHes. All of this is configurable from the
configuration file but can also be controlled from the command line.
Something like '-D /media/network1/mirror' (versions older than the
latest use '-d' instead of '-D') would have sbopkg look in that
directory for a hierarchy it recognizes. Something like '-V
Sbo/build-13.37' might tell it to use that. If that's not what's
actually going on, you might need to set ROOT to
/media/network1/mirror/Sbo, NAME to 'build-13.37' and not have a branch.
(If I'm remembering correctly - I don't use these features myself. If
I'm wrong, I'll look at the code later.) As far as the repos.d files,
those files want the repo (name) and the branch but don't expect the
REPO_ROOT to be specified in them - but I don't know what your file
looks like.

The best thing to do, however, if you don't have a reason not to, is to
use sbopkg's default local directory: /var/lib/sbopkg/local. Then a
simple ' sbopkg -V local' will activate that repo. That I do use, and
know that works as described.

And, at this point, if what I've said doesn't help, this is really more
material for sbopkg's own list (where I'd also appreciate everyone
signing up, for the same reasons Robby expressed.) :) There, more detail
on your filesystem and what your files actually say would be good.


More information about the SlackBuilds-users mailing list