[Slackbuilds-users] TexLive2013 Install Issue: Different Host

David Spencer baildon.research at googlemail.com
Mon Mar 24 18:34:29 UTC 2014

>   Fourth, I tried installing the build package, but the process hangs. I ran
> 'ps -efl' and directed output to a text file, but I don't know how to
> interpret the output. Manually running updmap showed some missing map files;
> I let the tool build replacements. Thinking this solved the installation
> problem, I re-ran installpkg. Still hangs. Manually running updmap indicates
> no problems.

Um, well, it's blocked within updmap just like the other one :-(

The trick is in the PID and PPID columns.  PID is the process ID, and
PPID is the parent PID.  Thus you can follow the tree of active
processes.  The obvious place to start is pid 5493 (installpkg), which
is the parent of 5644 (a subshell in installpkg), which is the parent
of 5645 (doinst.sh), which is the parent of 6568 (updmap).  6568 has
no child processes, and it has 'n_tty_' in the (truncated) WCHAN (wait
channel) field (the place in the kernel where the process is
sleeping).  So it's just like the previous problem :-(

Here are two alternative suggestions:

(1) finish the installpkg manually, by doing what the doinst.sh would
have done.  If your manual updmap does indeed finish ok, then the only
remaining issue is that you need to run this manually:

/usr/bin/fmtutil-sys --all

This is not 100% satisfactory as it doesn't store the doinst.sh script
and clean up, which is what installpkg would do between doinst.sh and
exiting, and the lack of a stored script will cause you more pain when
you eventually upgrade or remove the package.  You could/should try to
do that manually...

or (2) modify the SlackBuild's doinst.sh and rebuild the package. It's
a wild guess, I haven't tried it, and it's not a general solution, but
this might work for you:

chroot . /usr/bin/mktexlsr 1>/dev/null 2>/dev/null
chroot . sh -c "echo y | /usr/bin/updmap-sys --nohash --syncwithtrees"
chroot . /usr/bin/fmtutil-sys --all 1>/dev/null 2>/dev/null

Even if that doesn't work, it will at least give you some output to
see what updmap-sys is actually doing.  (or not)


More information about the SlackBuilds-users mailing list