[Slackbuilds-users] x2goserver issues

Konrad J Hambrick kjhambrick at gmail.com
Fri Oct 14 02:26:50 UTC 2016

Miguel --

I tried several months ago but never got it to work on Slackware64-14.2 +

Gave up without much debugging.

There several threads on LQ about it.

The x2goserver seems to not like Slackware ...

-- kjh

On Thu, Oct 13, 2016 at 12:56 AM, Miguel De Anda <miguel at thedeanda.com>

> has anybody tried running the x2go server lately? i've never managed
> to get it to work but while trying right now from client on ubuntu,
> and server on slackware i got stuck when trying to start the session.
> it appears that the ssh connection works but the scripts are having
> issues.
> after some debugging (not trivial to do so far) i discovered the
> following output:
> Connection failed. /usr/bin/x2gostartagent: line 25:
> /usr/lib/x2go/x2gosyslog: No such file or directory
> /usr/bin/x2gostartagent: line 82: /usr/lib/x2go/x2gosyslog: No such
> file or directory /usr/bin/x2gostartagent: line 188:
> /usr/lib/x2go/x2gogetdisplays: No such file or directory
> /usr/bin/x2gostartagent: line 196: /usr/lib/x2go/x2gogetports: No such
> file or directory /usr/bin/x2gostartagent: line 214:
> /usr/lib/x2go/x2goinsertsession: No such file or directory
> /usr/bin/x2gostartagent: line 188: /usr/lib/x2go/x2gogetdisplays: No
> such file or directory /usr/bin/x2gostartagent: line 196:
> /usr/lib/x2go/.................
> that appears to be the output of the remote script running from
> x2gostartagent. while looking for /usr/lib/x2go i discovered its not
> really there and that the script in /usr/bin/x2gopath has incorrect
> values for libexec (but maybe more).
> it seems that most files are in /usr/lib64/x2go/* but there is 1 in
> /var/lib/x2go (x2go_sessions)
> i'm guessing that the slackbuild script has issues but since i've
> never used x2go before, i can't say for sure.
> i didn't want to post on linuxpackages (yet) since this seems to be a
> slackbuild issue.
> thanks,
> miguel
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20161013/38f79e9e/attachment.html>

More information about the SlackBuilds-users mailing list