[Slackbuilds-users] fzf fails to build

Jostein Berntsen jbernts at broadpark.no
Sun Oct 30 18:43:28 UTC 2016

On 24.10.16,22:51, Matteo Bernardini wrote:
>2016-10-24 22:10 GMT+02:00 Jostein Berntsen <jbernts at broadpark.no>:
>> Building fzf after processing the package with sqg gives this error:
>> # _/tmp/SBo/fzf-0.13.5/src/fzf
>> /tmp/go-build733267827/_/tmp/SBo/fzf-0.13.5/src/fzf/_obj/_go_.o: In function
>> `main.AN36_github_com_junegunn_fzf_src$sizeSpec4e$hash':
>> /tmp/SBo/fzf-0.13.5/src/fzf/main.go:5: undefined reference to
>> `github_com_junegunn_fzf_src.sizeSpec$hash'
>> collect2: error: ld returned 1 exit status
>> Makefile:69: recipe for target 'fzf/fzf-linux_amd64' failed
>> make: *** [fzf/fzf-linux_amd64] Error 2
>> fzf:
>> Would you like to continue processing the rest of the
>> queue or would you like to abort?  If this failed
>> package is a dependency of another package in the queue
>> then it may not make sense to continue.
>Hi Jostein,
>google-go-lang installs file in /etc/profile.d that are loaded in your
>shell at login, so you have to logout and login again after having
>installed the package to use the correct go interpreter to build stuff
>(as fzf).


I rebooted and tried again, but still gets the same error.


More information about the SlackBuilds-users mailing list