[Slackbuilds-users] appstream-glib compile failure

Andrew Clemons aclemons at runbox.no
Thu Dec 21 18:41:25 UTC 2017


On 2017-12-21 15:29:46 -0300, ricardo at palmtx.com.ar wrote:
> Hi everyone!
> Slackware64 14.2, appstream-glib 0.7.4 fails to build for me:
> ninja: Entering directory `/tmp/sbopkg.zqThpw/appstream-glib-appstream_glib_0_7_4/_build'
> ninja: error: '../libappstream-glib/libappstream-glib/as-environment-ids.txt', needed by 'libappstream-glib/as-resources.c', missing and no known rule to make it
> Makefile:4: recipe for target 'all' failed
> make: *** [all] Error 1
> Notice the double "libappstream-glib/" in the "ninja: error:" line
> Tried 0.7.3, also fails, same error.
> Can anyone confirm?
> PS: I fixed it adding this sed before the make command, not sure if it's the right fix:
> sed -i -e "s,../libappstream-glib/libappstream-glib/,../libappstream-glib/,g" _build/build.ninja

I also noticed that last week's meson update broke it, but hadn't had
time to look more closely. Your change fixes it for me too. I'll submit an
update for it. Thanks!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20171222/b5a016ad/attachment.asc>

More information about the SlackBuilds-users mailing list