[Slackbuilds-users] How am I to handle two Apache Ant versions?

Jeremy Hansen jebrhansen+SBo at gmail.com
Fri Oct 11 23:22:02 UTC 2019

On Fri, Oct 11, 2019, 3:09 PM Luc Van Rompaey <luc.vanrompaey at gmail.com>

> Op vr 11 okt. 2019 om 04:24 schreef Jeremy Hansen <
> jebrhansen+SBo at gmail.com>:
>> I can't speak for the admins, but there shouldn't be any problem with
>> having two versions as long you don't break existing programs.
>> But to simplify, you may want to consider leaving the 1.9 version as just
>> apache-ant and then have the new one be apache-ant-1.10. This way you
>> don't need to go through and adjust all the SlackBuilds that already
>> require apache-ant to be apache-ant-1.9. Or if the intention is to
>> eventually get rid of the 1.9 version (even if it is for 15.0's release),
>> it may be worth labeling that as legacy and making the 1.10 version the
>> primary, but you'd need to check packages and make sure they work or have
>> their REQUIRES line be adjusted to apache-ant-legacy.
>> If they aren't compatible with each other, make sure it is mentioned in
>> the respective READMEs.
>> Good luck
>> Jeremy
> Didn't such a rename happen with 'openjdk' some time ago?
> I seem to remember getting an 'openjdk' SlackBuild, which IIRC was the
> OpenJDK 7 version.
> Nowadays, all of the OpenJDK SlackBuilds include the version number in
> their names.
> Would it cause any issues if 'apache-ant' were renamed (be it to
> 'apache-ant-1.9' or 'apache-ant-legacy') and I simply added a note to the
> README explaining the situation?

Yes, packages have been renamed in the past. But renames need to not break
existing packages, so all the REQUIRES lines for packages requiring
apache-ant would need to be updated to the new package name. The SBo admins
can do that, but you need to make sure you let them know when you upload
the package.

By the way, I don't think that Ant 1.9 should be removed, at least as long
> as gcc5 remains available (as it currently is in Ponce's repository),
> because if you install gcc5 and want to use Ant with it, then you will
> still need Ant 1.9.

If it serves a purpose, then it should stay in :)

But if the newer version is compatible with the older one and just has
different dependencies, it might not be worth maintaining both versions
once Slackware 15.0 is released. It definitely makes sense to keep 1.9 in
right now for 14.2 since it doesn't require any additional dependencies.
But I don't know enough about the software to determine if it's worth
maintaining both when both require dependencies (since with 15.0, it would
require gcc5).


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20191011/1e57abd6/attachment.htm>

More information about the SlackBuilds-users mailing list