[Slackbuilds-users] Pixma driver module for Canon scanner

Rich Shepard rshepard at appl-ecosys.com
Fri Jan 10 13:59:01 UTC 2020

On Fri, 10 Jan 2020, Christoph Willing wrote:

> I just dug up my old scanner (CanoScan LiDE 60) and plugged it in, after
> which XSane detected it immediately on startup without any additional
> driver being installed. Have you tried XSane? Also:


Yes, I've always used Xsane. It tells me it cannot find any device.

> chris at d7:~$ scanimage -L
> device `genesys:libusb:001:004' is a Canon LiDE 60 flatbed scanner
> device `epson2:net:' is a Epson PID 08C4 flatbed scanner
> device `epson2:libusb:002:003' is a Epson PID 08C4 flatbed scanner
> Just to reiterate - that result is without any Canon-specific driver
> added by me.

Interesting because here scanimage -L cannot find the scanner.

The LiDE 400 has no on/off switch. When it's connected to a USB 3.x port it
turns itself on and,

$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

To add to my confusion, as a user scanimage -L produces the above result.
Same result when run as root. Yesterday, sane-find-scanner worked for me as
a user, today it tells me I don't have permissions for any USB interfaces.
When run as root it finds the scanner:

# sane-find-scanner

found USB scanner (vendor=0x04a9 [Canon], product=0x1912 [LiDE 400]) at libusb:001:034

I'll download a Canon .rpm driver and try that later this morning.



More information about the SlackBuilds-users mailing list