[Slackbuilds-users] RTL8192 driver: source link broken.

ld.jay ld.jay at protonmail.com
Wed Jul 22 07:09:29 UTC 2020

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Tuesday, July 21, 2020 8:02 PM, B Watson <yalhcru at gmail.com> wrote:

> Have I got the right link?
> https://static.tp-link.com/2018/201805/20180514/TP-Link_Driver_Linux_series8_beta.zip

Yes, that's the right link.

> Hm. I just downloaded it with wget, with no problem.
> And downloaded it again, with curl. And with PaleMoon, and elinks...

Strange.  I'm using Palemoon, too, and for me, clicking the above link takes me to a page that says:
"Please go to TP-Link Offical Website to get products, software and services for your region."

But wget of the same link works like a charm.

I tried it in Palemoon w/ JS on and off, and even tried switching from "native" palemoon user-agent mode to "firefox compatibility" mode--no dice.

> ... If wget works
> for you, the README could be updated to say "If you have trouble
> downloading the source file, try using wget instead of a browser",
> something like that.

I think that's exactly what I'll do: I'll add such a line to the README.  In the mean time, since the link seems to be working for most, I won't lose any sleep over it.  (The user who alerted me to the "Please visit our homepage" message could just as easily click the HOMEPAGE link provided on SBo right above the source link and then download the source ZIP from there.)

Thanks for your feedback,

More information about the SlackBuilds-users mailing list