[Slackbuilds-users] Anki ModuleNotFoundError

Daniel Mackle gerswing at gmail.com
Sat May 21 05:05:26 UTC 2022

I have run into an error with anki since I upgraded to Slackware 15.0.  I
have re-installed all of the dependencies and still get the same error.
This includes and up to the latest version on Slackbuilds.  I have searched
the web, SBo mailing list archives, Anki mailing list, etc. and still have
not been able to resolve.  If anyone has any ideas, please let me know.

Anki builds just fine, but when I try to run I get the following error:

Traceback (most recent call last):
 File "/usr/bin/anki", line 5, in <module>
   from aqt import run
 File "/usr/lib64/python3.9/site-packages/aqt/__init__.py", line 39, in
   import anki.lang
 File "/usr/lib64/python3.9/site-packages/anki/lang.py", line 12, in
   import anki._backend
 File "/usr/lib64/python3.9/site-packages/anki/_backend/__init__.py", line
11, in <module>
   from markdown import markdown
 File "/usr/lib64/python3.9/site-packages/markdown/__init__.py", line 35,
in <module>
   from .__version__ import version, version_info  # noqa
ModuleNotFoundError: No module named 'markdown.__version__'

I believe it may have something to do with Python2.7/Python3.9, but I am
not sure.  Thank you in advance for any advice.  I do have Markdown


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20220521/ebbe797c/attachment.htm>

More information about the SlackBuilds-users mailing list