[Slackbuilds-users] Anki ModuleNotFoundError

Dave Woodfall dave at slackbuilds.org
Sat May 21 05:39:51 UTC 2022

On 21/05/22 14:05,
Daniel Mackle <gerswing at gmail.com> put forth the proposition:
> I have run into an error with anki since I upgraded to Slackware 15.0.  I
> have re-installed all of the dependencies and still get the same error.
> This includes and up to the latest version on Slackbuilds.  I have searched
> the web, SBo mailing list archives, Anki mailing list, etc. and still have
> not been able to resolve.  If anyone has any ideas, please let me know.
> Anki builds just fine, but when I try to run I get the following error:
> Traceback (most recent call last):
>  File "/usr/bin/anki", line 5, in <module>
>    from aqt import run
>  File "/usr/lib64/python3.9/site-packages/aqt/__init__.py", line 39, in
> <module>
>    import anki.lang
>  File "/usr/lib64/python3.9/site-packages/anki/lang.py", line 12, in
> <module>
>    import anki._backend
>  File "/usr/lib64/python3.9/site-packages/anki/_backend/__init__.py", line
> 11, in <module>
>    from markdown import markdown
>  File "/usr/lib64/python3.9/site-packages/markdown/__init__.py", line 35,
> in <module>
>    from .__version__ import version, version_info  # noqa
> ModuleNotFoundError: No module named 'markdown.__version__'
> I believe it may have something to do with Python2.7/Python3.9, but I am
> not sure.  Thank you in advance for any advice.  I do have Markdown
> installed.
> V/R
> Dan

It looks like Markdown (python2) might be conflicting slightly with
the stock python-markdown (python3) package.

Can you try uninstalling Markdown and reinstalling python-markdown to
see if it helps?


SBo templates:
How to format github downloads:

More information about the SlackBuilds-users mailing list