[Slackbuilds-users] tangogps slackbuild doesn't work

Donald Allen donaldcallen at gmail.com
Sun Aug 7 14:01:25 UTC 2011

On Fri, Aug 5, 2011 at 3:16 PM, Donald Allen <donaldcallen at gmail.com> wrote:

> I have reached the point where I've had enough problems with slackbuilds
> and I'm tired of the pain of slackware package management (or lack thereof)
> that I'm giving debian a try (I found that I could install it without a
> desktop environment, exactly what I wanted; I just run dwm) and I have to do
> it on the netbook for various reasons. So I no longer have slackware
> installed on that machine, so I won't be able to do further testing in a
> car.

Well, this was an interesting exercise, leaving me sheepishly coming back to
Slackware after a couple of days of experimentation. Having been reminded,
at my advanced age, that "convenience" exacts a price.

Debian's wireless stuff is flakey on my netbook, a showstopper. It worked,
and then it didn't; config files unchanged and correct, dhcpcd installed
properly. Plus, Debian's packages tend to be old, so for certain
applications where I care about having the most recent version, such as
gnucash, I'd be in the business of building from source, without the help of
slackbuild scripts and dependency information (building gnucash 2.4.7 was
not fun). Then there's the awful Sys V init setup and the general feeling
that Debian is too complicated.

Speaking of complicated, I then I spent some time trying Gentoo, which I
used for a couple of years in the past. Installation is a multi-hour
proposition, especially on a slow machine, and I found that X did not work
correctly on the machine where I tried it. It's also an ongoing maintenance
headache, which is the reason I gave up on it when it was my primary
distribution. Once I started having X problems, that was that.

I didn't even bother with Arch, which I tried a few years ago. Their rolling
release idea means that because they are continuously releasing new stuff,
they can't possibly test the whole system every time something new appears.
And occasionally, something new will appear that will blow up your system if
you install it, at which point you get to boot from a CD and learn how to
use chroot.

I have been running FreeBSD 8.2 on three of my machines and it's a solid
system. But yesterday, I tried to upgrade gnucash to 2.4.7, that version
having appeared in /usr/ports after an update. One of the standard port
management tools (portmaster) failed miserably in managing the upgrade,
leaving me with a gnucash executable that segfaulted immediately. Various
attempts to rescue the situation failed. Getting to gnucash 2.4.7 with
slackware is easy. I have a home-brew make-based tool that I use to wget
slackbuilds, source files, info files, etc. from slackbuilds.org and
whatever it points to. Dependencies are expressed in the makefile. I had
built 2.4.5 using this (that's the current version available from
slackbuilds.org), so all the dependencies were installed, and therefore
upgrading to 2.4.7 was a simple matter of downloading the source tarball and
running the slackbuild script manually. When I realized how easy this was,
compared to what I had been through with debian and freebsd, it dawned on me
that I was heading in exactly the wrong direction, away from from slackware.
So I'm back, chastened. The moral of the story is that while things in the
Slackware world aren't perfect, for my minimalist tastes (I don't run a
desktop environment, just dwm with some of the standard patches, one of
which I contributed), it's better for me than anything else I can find. Live
and learn.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20110807/a422646a/attachment.html>

More information about the SlackBuilds-users mailing list