[Slackbuilds-users] Sage build fail

JCA 1.41421 at gmail.com
Mon Mar 27 14:10:05 UTC 2017

I tried again, in the 6 GB RAM/ 3 GB swap system. Just to clarify: this is
a 64-bit 14.2 that I installed just a few days ago. The first thing I did
after installing it was to upgrade every single package found in the
patches/packages directory. I installed other packages from slackbuilds
afterwards, including the previous version of sage. The only difference
between my previous run in this system, and this one, is that X was not
running this time. In both cases, I launched the built directly - i.e. by
downloading the relevant files from slackbuilds.org - no sbopkg.

In a nutshell, the build succeeded, and the package was created all right.
This is what happened when I issued the upgradepkg command on this package:

Verifying package sage-7.5.1-x86_64-1_SBo.tgz.
Installing package sage-7.5.1-x86_64-1_SBo.tgz:
# sage (python based mathematics software)
# Sage is a free open-source mathematics software system licensed under
# the GPL. It combines the power of many existing open-source packages
# into a common Python-based interface.
# Mission: Creating a viable free open source alternative to Magma,
# Maple, Mathematica and Matlab.
# Home: http://www.sagemath.org
Executing install script for sage-7.5.1-x86_64-1_SBo.tgz.
â.. SageMath version 7.5.1, Release Date: 2017-01-15                   â..
â.. Type "notebook()" for the browser-based notebook interface.        â..
â.. Type "help()" for help.                                            â..

ERROR:  The Sage installation tree has moved

from /tmp/SBo/sage-7.5.1
  to /opt/sage

This is not supported, and Sage will not work. To install Sage from a
binary package:

1. Open the .tar.bz2 archive (or .dmg on OSX)

2. Move the SageMath folder/app to where you want it to be. You can
   also rename the directory now.

3. Start sage for the first time. This will then automatically patch
   paths in binaries.

After starting Sage for the first time you cannot change the
installation any more. To install Sage elsewhere, start over from the
binary package. Or recompile Sage from scratch in the new location
("make distclean && make")

Package sage-7.5.1-x86_64-1_SBo.tgz installed.

Package sage-7.2-x86_64-1_SBo upgraded with new package

However, when I invoke 'sage' from the shell, I do get the sage CLI, and it
seems to be fully functional. I am guessing that the installation script is
heeding the instructions above.

On Mon, Mar 27, 2017 at 12:36 AM, Christoph Willing <
chris.willing at iinet.net.au> wrote:

> On 27/03/17 13:53, Christoph Willing wrote:
> > On 27/03/17 12:52, Willy Sudiarto Raharjo wrote:
> >>  I tried on yet another system, again 64-bit 14.2, this time with 6 GB
> >>> and 3 GB swap, running XFCE but nothing else, and I am getting the same
> >>> result. I'll try again, this time without X running.
> >>
> >> Just to make sure to run a complete installation of Slackware{64}-14.2
> >> with the latest patch is preferred.
> >>
> >> Notes:
> >> my last build of sage was in March 9, so i haven't tried it again since
> then
> >>
> >
> > I just built 7.5.1 (March 9 update) in a full x86_64 14.2 VM without any
> > problems.
> >
> > However on installation, the running of sage (from doinst.sh) fails with
> > "ERROR:  The Sage installation tree has moved" error - full message
> > attached. The same message is  shown when running sage from the command
> > line.
> >
> I made a new build which commented out running of sage from doinst.sh.
> According to the /opt/sage/sage script, running it the first time runs
> relocate-once.py and then deletes it. I wanted to look at
> relocate-once.py before it was deleted so had to stop sage being run by
> doinst.sh. The new build and installation went well - sage didn't run.
> However relocate-once.py still wasn't in SAGE_ROOT as expected - I can't
> find it in the sage package that was installed either.
> In fact I couldn't see relocate-once.py in the source tarball either so
> I presume it should be generated at build time. Since it's not in the
> final package, I'm guessing that it hasn't been generated. That would
> explain the error message about not being able to run after being
> relocated.
> chris
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users at slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - https://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - https://slackbuilds.org/faq/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.slackbuilds.org/pipermail/slackbuilds-users/attachments/20170327/e2b9930a/attachment.html>

More information about the SlackBuilds-users mailing list